• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6200
  • Last Modified:

Outlook manual archive not archiving subfolders.

Hi guys,

I have replicated this problem across Outlook 2003, 2007 and 2010.

When manually archiving a mailbox by date, it doesnt reliably move all the emails in subfolders to the archive as expected.

I have done a bit of reading and everyone points to the modified date as the date it archives by and *not* the received date. But that only explains *some* of the emails not moving. There is a larger majority that dont get archived that I am yet to find an explanation for.

E.G. a subfolder in the inbox has emails with received dates rangeing from 2011 to 2009.
I archived from Jan 1 2011 and none of the emails got moved.
The modified date for a lot of the emails match the received date and there is a small quantity where the modified date is new than the received date.
However none of the emails were archived.

What am I missing?



0
defecta
Asked:
defecta
  • 6
  • 3
1 Solution
 
Rob HensonFinance AnalystCommented:
Do the individual items have the "Do Not Autoarchive" box ticked?

Open the item and select properties from the File Menu. Towards the bottom, tick box for "Do not Autoarchive this item".

If this is ticked, you will have to tick the box for "Include items with "Do Not Autoarchive" checked" in the Archive window.

Thanks
Rob H
0
 
defectaAuthor Commented:
Negative. The mail items do not have the 'do not autoarchive' box ticked.

And when I ran the manual archive I had the "Include items with 'do not autoarchive' checked" ticked also.

Are you telling me that I need to change all mail items to have the "do not autoarchive" option set? Or are you just giving an example on how to find the setting?

Upon checking just now though, the subfolders themselves are set for "do not autoarchive" which is the default setting for newly created subfolders.

Even though I ticked the box to "Include items with 'do not autoarchive' checked" could the subfolder settings be the issue do you think?
0
 
Rob HensonFinance AnalystCommented:
Sounds like it could be the folder settings.

If I recall correctly there is a setting in the folder settings for archiving specific folder as per general rule or parent folder.

I doubt I will get time to check it tomorrow or Friday but might be able to over the weekend.

Rob
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
defectaAuthor Commented:
Ok so if I am understanding you correctly, the folder archive settings will override manual archive settings and prevent the files from being archived unless they are all modified?
0
 
Rob HensonFinance AnalystCommented:
Just taken a look at my Outlook and have the following properties: (Right click folder, Properties, AutoArchive tab)

Inbox - Set to Archive using the default settings
Subfolder - Set to Archive using the default settings
Subsubfolder - Set to Do Not archive items in this folder

Eventhough the last one is set to Do Not archive contents of this folder, they get archived eventhough the "Include items with 'do not autoarchive' checked" is NOT ticked!! Hows that for bizarre?

In the AutoArchive settings, there isn't an option for "Include items with 'do not autoarchive' checked".

Thanks
Rob H
0
 
defectaAuthor Commented:
Yeah the behaviour is totally not consistent and in my opinion, buggy.

And I am pretty sure the *AUTO*archive folder settings are not acknowledged by a manual archive operation performed by the user as they are two different operations.

There doesn't appear to be an answer to the problem other than manually scouring the inbox and subfolders and moving the emails it misses. :(
0
 
defectaAuthor Commented:
I have read elsewhere on this topic that when manually archiving the "archive from" date is based on the date the email was modified and not the date it was sent/received. =/

By default, Archiving works based on the modified date of an item. The modified date of an item can be viewed by opening the item and then choose File-> Properties. The item will only be archived when the modified date of the item is older than the date set for archiving. Actions that can cause the modified date to change are;

    reply
    reply to all
    forward
    move to another folder
    editing
    saving
    importing

Changing Archive to sent/receive date
To change the Archive feature to function on the sent/received date of an item instead of on the modified date, you must have the following updates installed;

    Outlook 2007: The revised version of update KB2412171 (January 2011) or later.
    Outlook 2010: Hotfix KB2516474 (April 2010) or later (like Service Pack 1)

After applying the update or Hotfix, you can enable the option via the Registry;

Key for Outlook 2007:
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Preferences
Key for Outlook 2010:
HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences

Value name: ArchiveIgnoreLastModifiedTime
Value type: REG_DWORD
Value: 1

E-mail messages will now be archived based on their Received date, Calendar items based on their scheduled date and Task items based on their Completed date. For more information about the new and old behavior for archiving see KB2500686 (Outlook 2007) and KB2553550 (Outlook 2010).
See this link for more detail and the links to the above mentioned KB articles. http://www.howto-outlook.com/faq/archivenotworking.htm
0
 
defectaAuthor Commented:
This is the most complete explanation of my issue that I could find.
0
 
spike_grooverCommented:
Did not fix my issue and I used Solution to find out.
0
 
defectaAuthor Commented:
@spike_groover: could you give a more detailed explanation of what your issue is? Or perhaps open your own thread if its too different from this one?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now