• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 938
  • Last Modified:

Missing ASP.Net Section on IIS 7

I'm setting up a development windows 7 machine (actually virtual machine on a mac) and everything as expected except - in IIS Manager I see no ASP.NET options even though I've added application pool and my application etc.
I think I'm missing something fundamental so be happy if someone could help me out.
Thanks iis-screenshot.tiff
1 Solution

Your problem may be that you've installed IIS,
but not the ASP.NET features. To check this, goto the
Turn Windows features on or off' dialog (typing 'features' into Start Menu search will get you there) then navigate through as follows:
- Internet Information Services (IIS)
-- World Wide Web Servies
--- Application Development Features
---- ASP.NET
Ensure that ASP.NET is ticked
(which will probably enable a host of other features too) then try again.

nigelr99Author Commented:
Thanks - I thought it would be something 'fundamental'.

For general information, after installing asp.net features my test site gave some 'bad module' errors which apparently were due to 'incomplete installation' so I found and ran the following and everything now fine!

%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now