Solved

SCCM WSUS update sync fails

Posted on 2011-09-13
13
3,854 Views
Last Modified: 2013-11-21
Hi all,

I have been having issues with SCCM/WSUS updates failing to automatically synchronise updates on a schedule.

My WSYNCMGR.log shows :-

Sync failed: There is an error in XML document (129, 22981430). Source: Microsoft.UpdateServices.Internal.ApiRemoting.ExecuteSPSearchUpdates

... and it will retry every hour, failing with the same error.

If I do a manually initiated "Syncronise" from the SCCM console all appears to run through OK until the next scheduled automatic sync when the error starts again.

Not alot seems to be documented ont he web about this - Any ideas anyone?

cheers
0
Comment
Question by:MarkieS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
13 Comments
 
LVL 6

Assisted Solution

by:emadallan
emadallan earned 350 total points
ID: 36528675
this issue occur when this particular SCCM service and the SCCM backups are running in the same time just adjust the synchronization to happen 2 hours after the backup.
this will prevent them to run simultaneously.
0
 
LVL 8

Author Comment

by:MarkieS
ID: 36528728
SCCM backups are scheduled for 5am on a Sunday morning.  The backup is not running.  

SCCM Updates sync is set to 13:00 and every 12 hours (Set at a high rate to troubleshoot this problem!)

Run a manual sync all is OK.  When an automatic sync runs the error occurs.

I have changed the Automatic schedule to run at 10pm, once a day

Will check back tomorrow...

cheers
0
 
LVL 6

Expert Comment

by:emadallan
ID: 36529526
ok, during this time, check to see which sccm support services could be running in the same time with the particular sccm service.
i am sure 100% that your problem is due to sccm service is running with another one at the same time.
so make an investigation!
0
MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

 
LVL 8

Author Comment

by:MarkieS
ID: 36541680
Cheers..
Still same results.  
I have disabled both the SMS_SITE_SQL_BACKUP and the SMS_SITE_BACUP services to stop them running.
Rebooting the server - lets see what happens tomorrow...
0
 
LVL 8

Author Comment

by:MarkieS
ID: 36542198
The SMS_SITE_SQL_BACKUP service is running all the time.  Is this normal?

If I stop the service it restarts automatically.

If I disable the service SCCM detects a problem and re-installs and thus restarts the service.

Any ideas?
0
 
LVL 6

Expert Comment

by:emadallan
ID: 36542399
just run
net stop SMS_SITE_VSS_WRITER
net stop SMS_SITE_SQL_BACKUP
without restarting your machine
and scedule the sccm auto synch to run just after running these commands.
 and let me know what happen?
0
 
LVL 31

Assisted Solution

by:merowinger
merowinger earned 150 total points
ID: 36542460
Check out the smsbkup.log file maybe there's an error
0
 
LVL 6

Expert Comment

by:emadallan
ID: 36542850
one thing to mention is that our discussion assume that the service that is interfering with particular sccm service is backup, but it could be another one, for this i said before to make which one cause the problem! may be it is not the backup service!
0
 
LVL 8

Author Comment

by:MarkieS
ID: 36542897
Hi merowinger,

The smsbkup.log shows it is running every Sunday morning as expected for about 1/2 an hour.  It's last entry being "SMS site backup service stopped." - no errors

The smssqlbkup.log shows it is running all the time with entries every 30 minutes of
"No message received in the last 30 minutes..." - no errors



Hi emadallan,

I have rescheduled the AutoSync for 14:36.
I have applied your suggestion.. at 14:35

Wsyncmgr.log shows:
Syncing all updates      SMS_WSUS_SYNC_MANAGER      15/09/2011 14:36:07      5760 (0x1680)
requested update classifications: Critical Updates, Definition Updates, Drivers, Feature Packs, Security Updates, Service Packs, Tools, Update Rollups, Updates      SMS_WSUS_SYNC_MANAGER      15/09/2011 14:36:07      5760 (0x1680)
sync: SMS synchronizing categories      SMS_WSUS_SYNC_MANAGER      15/09/2011 14:36:07      5760 (0x1680)
sync: SMS synchronizing categories, processed 0 out of 163 items (0%)      SMS_WSUS_SYNC_MANAGER      15/09/2011 14:36:07      5760 (0x1680)
sync: SMS synchronizing categories, processed 100 out of 163 items (61%)      SMS_WSUS_SYNC_MANAGER      15/09/2011 14:36:08      5760 (0x1680)
sync: SMS synchronizing categories, processed 163 out of 163 items (100%)      SMS_WSUS_SYNC_MANAGER      15/09/2011 14:36:08      5760 (0x1680)
sync: SMS synchronizing updates      SMS_WSUS_SYNC_MANAGER      15/09/2011 14:36:08      5760 (0x1680)


Kept checking to ensure both services were not running while waiting for wsyncmgr.log

SMS_SITE_SQL_BACKUP service started itself again at 14:37...

The wsyncmgr.log was still sitting on "sync: Starting SMS database synchronization"

It finally errored at 14:42....

Looks like it must be another service clashing with it...  I'll keep looking..

cheers guys/gals..?
0
 
LVL 8

Accepted Solution

by:
MarkieS earned 0 total points
ID: 36580447
Finally cleared this by installing .Net4.0 - Bingo!
0
 
LVL 8

Author Closing Comment

by:MarkieS
ID: 36708077
Finally resolved myself.  Good replies and trains of thought guys/gals!

Many thanks for your help thanks for taking the time to assist.
0
 

Expert Comment

by:frieda211
ID: 38921130
mind to share how you resolved this?
i have uninstall SUP, reinstall WSUS , add SUP again & after sync ..all  updates still show grey.
i am still not able to create any deployment with message all metadata expired.
0
 
LVL 8

Author Comment

by:MarkieS
ID: 38921288
Hi
An install of .Net 4.0 on the SCCM server fixed the issue for me in the end.

I am no longer working with this same SCCM system so it may be best to ask for assistance by raising a new question.

Kind regards
MarkieS
0

Featured Post

Enroll in May's Course of the Month

May’s Course of the Month is now available! Experts Exchange’s Premium Members and Team Accounts have access to a complimentary course each month as part of their membership—an extra way to increase training and boost professional development.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Problem Description: Actually I found the below issue with some customers after migration from SMS 2003 to SCCM 2007 and epically if they change site code, some clients may appear in the console with old site code, plus old sites still appearing …
Hi Everyone I posted previously on how I used Orchestrator to integrate with VMware and SCSM to create or request a new VM in VMware. Now in my Self Service Portal I had a list user input option that would require me to update the list of reso…
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question