Solved

Changing the primary domain dns name of this computer is failed

Posted on 2011-09-13
6
2,063 Views
Last Modified: 2012-06-27
Hi Experts,
                                  When windows 7 workstation is joined to domain. We are getting the error which is " Changing the primary domain dns name of this computer is failed"  and also after this error it will ask to restart the machine. Once the machine is restarted its successfully added to the domain. But A record in the dns not found. But the computer account is added to Active directory.

if we check event viewer we find the event id: 1014.(DNS client events) . Please get me soultion for this issue. Its bit urgent.
             
0
Comment
Question by:columbuseng
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 10

Accepted Solution

by:
gaurav05 earned 500 total points
ID: 36529084
Hi,

please run the following commands as an administrator

Please run the following command in an elevated command prompt in Windows 7:

netsh interface tcp set global rss=disabled
netsh interface tcp set global autotuninglevel=disabled
netsh int ip set global taskoffload=disabled

Disable SNP in Windows 7 by setting Registry (please perform a full-system backup first.
) as following:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
EnableTCPChimney=dword:00000000
EnableTCPA=dword:00000000
EnableRSS=dword:00000000

If the keys do not exist, please create them and assign the value.

let us know and feel free to discuss with us.
0
 

Author Comment

by:columbuseng
ID: 36529364
hi experts

we have done fallowe this setp but no resulation

netsh interface tcp set global rss=disabled
netsh interface tcp set global autotuninglevel=disabled
netsh int ip set global taskoffload=disabled

Disable SNP in Windows 7 by setting Registry (please perform a full-system backup first.
) as following:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
EnableTCPChimney=dword:00000000
EnableTCPA=dword:00000000
EnableRSS=dword:00000000

0
 
LVL 10

Expert Comment

by:abhijitwaikar
ID: 36531961
Hi,
Try below:
1. Click Start, click Run, type# regedit, and then click OK
2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Win dowsNT\Rpc
3. Click the Edit menu, point to New, and then click DWORD Value.
4. Type Server2003NegotiateDisable as the name of the new DWORD Value
5. Right-click Server2003NegotiateDisable, and then click Modify.
6. In the Value Data box, type 1, and then click OK.

If the registry subkey "Rpc" is missing in the described location in Windows 7. you may add the "Rpc" subkey and create the DWORD value as described.

Once that is done, reboot the Ws and try to add the computer into the domain.

Regards,
Abhijit Waikar.
----------------------
MCSA|MCSA:Messaging|MCTS|MCITP:SA
My blog: http://abhijitw.wordpress.com/
0
Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

 

Author Comment

by:columbuseng
ID: 36534290
Hi abhijitwaikar:

                               After these registry entries also im received the same error. Is there any other soultion for this issue
0
 
LVL 10

Expert Comment

by:gaurav05
ID: 36535729
Hi,

Verify that NetBIOS over TCP/IP is enabled.

a) Click Start , click Run , type ncpa.cpl , and then click OK .
b) In Network Connections , right-click Local Area Connection , and then click Properties .
c) Click Internet Protocol Version 4 (TCP/IPv4), and then click Properties .
d) In the Internet Protocol Version 4 (TCP/IPv4) Properties dialog box, click Advanced .
e) On the WINS tab, verify Enable NetBIOS Over TCP/IP is enabled, and then click OK three times.


OR

Verify end-to-end network connectivity over UDP port 137 over the network path connecting the client being and the helper DC serving the join operation.



0
 
LVL 10

Expert Comment

by:gaurav05
ID: 36535915
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article demonstrates probably the easiest way to configure domain-wide tier isolation within Active Directory. If you do not know tier isolation read https://technet.microsoft.com/en-us/windows-server-docs/security/securing-privileged-access/s…
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question