0509-150 Dependent module libjox9.a(shr.o) could not be loaded

AIX apaut146 2 5
oracle 9.2.0.8.0
I can log into sqlplus as oracle but not as myself.
I have ORACLE_HOME, ORACLE-SID, LIB_PATH and LD_LIBRARY_PATH set correctly.

Receive the following when trying sqlplus:
exec(): 0509-036 Cannot load program oracleepmprd9i because of the following errors:
        0509-150   Dependent module libjox9.a(shr.o) could not be loaded.
        0509-022 Cannot load module libjox9.a(shr.o).
        0509-026 System error: A file or directory in the path name does not exist.
ERROR:
ORA-12547: TNS:lost contact

as oracle I can do ldd /db/oracle/app/oracle/product/9.2.0/bin/sqlplus

/db/oracle/app/oracle/product/9.2.0/bin/sqlplus needs:
         /usr/lib/libc.a(shr_64.o)
         /usr/lib/libpthreads.a(shr_xpg5_64.o)
         /usr/lib/libdl.a(shr_64.o)
         /usr/lib/libodm.a(shr_64.o)
         /usr/lib/libc.a(aio_64.o)
         /unix
         /usr/lib/libcrypt.a(shr_64.o)

but as myself I cannot run ldd

I think it is some kind of permissions problem.

Thanks
LVL 1
bkreynolds48Asked:
Who is Participating?
 
slightwv (䄆 Netminder)Connect With a Mentor Commented:
Check your environment variables.

Specifically LD_LIBRARY_PATH and LIBPATH:

http://www.experts-exchange.com/Database/Oracle/Q_24711091.html
0
 
bkreynolds48Author Commented:
If you read the first part --- I HAVE checked all the environment variables.
0
 
slightwv (䄆 Netminder) Commented:
Apologies.  Missed that.
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
bkreynolds48Author Commented:
I think this may be a compile/link problem which I can't fix now because it is prod
0
 
slightwv (䄆 Netminder) Commented:
>>may be a compile/link problem

If that were the case I would expect the oracle user to have the same issue.

If the environments match 100% then I tend to agree with you that it is a permissions issue which leads to an installation/configuration problem not a link problem.

Just a gut feeling at this point.

Tripple check the environment variables.  I would even try a brute force method.  Log in as oracle and do a printenv > /tmp/junk.sh

edit junk.sh to issue the export commands and run it when logged in as your user to see if you can reproduce the issue.
0
 
bkreynolds48Author Commented:
did (printenv - export variables) that with tjhe same results.
0
 
bkreynolds48Author Commented:
if I do sqlplus username@database name it works
0
 
slightwv (䄆 Netminder) Commented:
>>if I do sqlplus username@database name it works

Not sure how else to help you here.  Maybe another Expert will have an idea later.
0
 
bkreynolds48Author Commented:
tns issue not env
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.