• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 298
  • Last Modified:

Block Usb Storage Devices

Hello,

I am unable to fix this problem from last couple of days. I tried all the way to block USB using group policy but I am unsucceeded. Anyone help me how to fix this problem clearly(step to step procedure).

Procedure I Tried :

1) Creating OU in active directory
2) Adding users and computers to that OU
3) Go to OU properties select group policy, Under group policy click on OPEN tab to open Group Policy Management.
4) Create one Group Policy and link it to OU.
5) Right Click on that Group Policy and Edit.
6) Group Policy Object Editor screen will appears.
7) Right Click on Administrative Templates under Computer Configuration select Add/Remove Template.
8) Add .ADM file which is downloaded from Microsoft site.
9) In Group Policy Object Editor Right Click on Administrative Templates under Computer Configuration select VIEW > Filtering.
10) Click to un-select the "Only show policy settings that can be fully managed" check-box. Click Ok.
11) Computer Configuration > Administrative Templates > Custom Policy Settings > Restrict Drivers, Now you will be able to see the new settings in the right pane.
12) Double Click on Disable USB Removable Drivers, Check the Enable option stopped the usbstore.sys driver option and then click on ok


After completion of this process, I login into a workstation with restricted user account , Then I inserted a usb drive in that machine USB port, But I found it is detecting.

Advice?

Maby Security settings from the gpo side?

0
Senx
Asked:
Senx
  • 2
1 Solution
 
AdamJurCommented:
run gpresult from command line to tell whether the Group Policy is actually being applied.

If not listed:  run>   gpupdate /force

check gpresult again.

If the policy appears to be applied check the windows event logs to see if there were errors applying the group policy.

take that custom ADM and apply it locally instead. from your workstation, run gpedit.msc and import the adm you created. perform gpupdate /force or reboot. If this still fails then your ADM is probably configured incorrectly.

Hope this sets you in the right direction.
0
 
SenxAuthor Commented:
Yes
its still fail
0
 
SenxAuthor Commented:
There is another ideas how to deal with that issue?

thanks.
0
 
Rob MinersCommented:
See if this helps

Deploying Custom Registry Changes through Group Policy

http://blogs.technet.com/b/askds/archive/2007/08/14/deploying-custom-registry-changes-through-group-policy.aspx


How can I prevent users from connecting to a USB storage device?

http://support.microsoft.com/default.aspx?scid=kb;en-us;823732
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now