Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Primary DC time is wrong

Posted on 2011-09-13
10
Medium Priority
?
484 Views
Last Modified: 2012-05-12
I have a 2008 DC that is 5 min. ahead. I am unable to manually adjust the time. I know the setting must be in the registry, but what are the steps to correcting this? Also all the client computers and other server are syncing time with this Server.

Thanks
0
Comment
Question by:jkellyg78
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 57

Expert Comment

by:Mike Kline
ID: 36530116
So is this the PDC emulator in the forest root?  See if you have it set to sync with an external time source.  Matt has a good blog entry on time here    http://tigermatt.wordpress.com/2009/08/01/windows-time-for-active-directory/

Thanks

Mike
0
 
LVL 10

Expert Comment

by:abhijitwaikar
ID: 36531459
One more article for whichever DC is configured as PDC Emulator role owner in your forest root domain.

- Configuring the Windows Time Service:
http://www.windowsnetworking.com/articles_tutorials/Configuring-Windows-Time-Service.html
0
 
LVL 24

Expert Comment

by:Sandeshdubey
ID: 36534370
check that the server is not synchronising the time with thirdy part time server.Check the servies on the server is there any thirdy part time service.Uninstall the same if not required.
Install the latest Daylight saving patch on the server if not installed.
Configure the authoritative time server: http://support.microsoft.com/kb/816042
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 3

Expert Comment

by:saurabhsehgal
ID: 36541413
Check the resgistry under HKML->system->current comtrol set->services->w32time->parameters ,check  type is set to NTP and NTPServer is poiting to external time source

Resync the time using commands

w32tm /resync [/computer:<computer>]

Check teh article for w32 commands

http://technet.microsoft.com/en-us/library/cc773263(WS.10).aspx
0
 

Author Comment

by:jkellyg78
ID: 36542365
I tried some of the solutions, but when I do a w32tm /resync command its changes for like ten seconds. The it changes its self back to being 5 minutes ahead. Any ideas?
0
 
LVL 24

Accepted Solution

by:
Sandeshdubey earned 2000 total points
ID: 36547221
It seems that the server  is synchronising time with other time server.
check the setting in registry HKLM\System\CurrentControlSet\Services\W32time\TimeProviders\NtpClient.check the SpecialPollTimeRemaining key what is the sting value.

Check  HKLM\System\CurrentControlSet\Services\W32time\Parameter.Check NtpServer value is it pointing to correct time source.

Check is the daylight saying is enabled on Date and Time properties.You can run timedate.cpl and it will open the  Date and Time properties.

It this server a physical server or it is a VM.In case if it is hosted on hyper-V check that it is not synchronising the time with HyperV host.

Restart the time service and ran w32tm /resyn /rediscover and check if  it is sync the time.

0
 
LVL 24

Expert Comment

by:Sandeshdubey
ID: 36547223
Check  HKLM\System\CurrentControlSet\Services\W32time\Config.Check AnnounceFlags value isset to 5.
Restart the time service and ran w32tm /resyn /rediscover and check if  it is sync the time.

0
 

Author Comment

by:jkellyg78
ID: 36549438
IT is a VM on Hyper-V. Sorry forgot to mention that. How do you stop it syncing time? On the Hyper-V host side or the client Side? Thanks,
0
 

Author Comment

by:jkellyg78
ID: 36549514
Never mind I know how to do it. It’s under the VM settings within Hyper-V Manager. You have to select Integration Services. Then you just have to uncheck the box for Time Synchronization. Thanks for the Direction Sandeshdubey... I'll let you know if it doesn’t work...
0
 
LVL 24

Expert Comment

by:Sandeshdubey
ID: 36555385

On the physical host.
Turn off Time Sychronization in Integration Services
http://blogs.technet.com/b/chrad/archive/2009/08/28/fighting-hyper-v-physical-host-time-drift-utilizing-ntp-to-synchronize-clocks.aspx

On the VM server
1) Disable the Hyper-V Time Synchronization Service inside the VM.
2)Delete the following registry subtree: HKLM\SYSTEM\CurrentControlSet\Services\w32time\TimeProviders\vmictimeprovider
3)Set the correct time on the server and reboot the server.
4)Configure authorative time on the server.http://support.microsoft.com/kb/816042

Note:Backup the resgistery before you proceed.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
Wouldn't it be nice if objects in Active Directory automatically moved into the correct Organizational Units? This is what AutoAD aims to do and as a plus, it automatically creates Sites, Subnets, and Organizational Units.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
Suggested Courses

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question