[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

FM - Navigating to a 2nd Portal Issue

Posted on 2011-09-13
12
Medium Priority
?
553 Views
Last Modified: 2012-05-12
I've had this problem before where I cannot seem to navigate to the second created portal on a layout, even when I give it a different object name and use a GotoObject script step.  It seems to want to default to the first created portal or nothing.  See screen print.  I can go to the tab Surrender, but not to the field in the portal.  (Note that this portal is the same as one on the main screen, using the same fields, etc. save that the Notes field has a different object name, NotesEntry_Surr instead of NotesEntry.
2ndPortalIssue.JPG
0
Comment
Question by:rvfowler2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
12 Comments
 
LVL 25

Expert Comment

by:Will Loving
ID: 36530512
In theory, you shouldn't need the GoToObject for  the tab, it should just go to the field Object...
0
 
LVL 2

Author Comment

by:rvfowler2
ID: 36530721
Yes, I know, but at least that gets my user to the tab.  It seems not to recognize the GotoObject for some reason even though I copied and pasted it in.
0
 
LVL 25

Expert Comment

by:Will Loving
ID: 36530759
Just for troubleshooting purposes, try a different Object name for the field doing GoToObject to a different field or object on the tab.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Author Comment

by:rvfowler2
ID: 36531485
I removed all steps except the GotoObject step and it will go to any other field on the Surrenders tab, except the NoteEntry_Surr field.  :)
0
 
LVL 2

Author Comment

by:rvfowler2
ID: 36531505
However, the whole FM window does blink for a moment when I press the execute script button.
0
 
LVL 25

Accepted Solution

by:
Will Loving earned 2000 total points
ID: 36531605
Sounds like you have a script trigger attached to that field that fires on OnObjectEnter. If that's not it you can also try deleting the field and then adding it back to the layout.
0
 
LVL 2

Author Comment

by:rvfowler2
ID: 36531691
No, there is only a script on key modification.  I finally worked around it by going to the previous field using a GotoObject and then using the Go to Next Field.  But I shouldn't have to do this.  Yes, and I've already deleted the field and copied it from the other one on the main screen that does accept a GotoObject.
0
 
LVL 25

Assisted Solution

by:Will Loving
Will Loving earned 2000 total points
ID: 36531734
Try turning off the script trigger and see if it works with it off.
0
 
LVL 2

Author Comment

by:rvfowler2
ID: 36532013
No, it didn't.
0
 
LVL 25

Assisted Solution

by:Will Loving
Will Loving earned 2000 total points
ID: 36532108
Hmmmm, the "flash" that you describe is so indicative of a script running...if you have the script debugger turned on and a script is running, it should show up in the debugger...

Does is possibly have an Auto-Enter Calculation that runs on entry, meaning the "Do Not Replace Existing Value..." checkbox is NOT checked?

Does it make any difference if you manually add the field using the Field tool rather than by copying and using a field from another layout?
0
 
LVL 2

Author Comment

by:rvfowler2
ID: 36535834
Remember above that I had narrowed it down to where I was only using the GotoObject script step in its own script and it still wasn't working, so no script triggers and no there was not any auto enter Calcs on the Notes field.  HOWEVER, came in the morning and the GotoObject script step worked fine.  Must have needed a reboot because I did recreate the field, did copy and paste the Object name into the script step, etc.  Frustrating, but at least it's solved.  However, your suggestions about checking for auto enter and script triggers will really help me in future trouble shooting.
0
 
LVL 2

Author Closing Comment

by:rvfowler2
ID: 36535845
Giving credit as I have a couple of tips for future troubleshooting.
0

Featured Post

Enroll in October's Free Course of the Month

Do you work with and analyze data? Enroll in October's Course of the Month for 7+ hours of SQL training, allowing you to quickly and efficiently store or retrieve data. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Pop up windows can be a useful feature of any Filemaker database.  Though best used sparingly, they can be employed in a multitude of different ways, for example;  as a splash screen at login, during scripted processes to control user input, as pick…
Problem: You have a hosted FileMaker database and users are tired of having to use Open Remote or Open Recent to access the database. They say, "can't you just give us something to double-click on rather than have to go through those dialogs?" An…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question