Solved

Avoid template parameter on Joomla

Posted on 2011-09-13
11
234 Views
Last Modified: 2012-08-13
I would like to avoid links like this: http://www.mediacionyparticipacion.com/index.php?tmpl=component

for just accepting links like this: http://www.mediacionyparticipacion.com/index.php
or like this: http://www.mediacionyparticipacion.com/mediacion?top=1

Is this possible ? I mean, is it possible to avoid tmpl=component or even tmpl=anything on our production site ?

Thank you
0
Comment
Question by:gplana
  • 6
  • 5
11 Comments
 
LVL 12

Expert Comment

by:Panagiotis S
ID: 36530598
try to use SEF

you can use joomla default or an external component like sh404sef
0
 
LVL 15

Author Comment

by:gplana
ID: 36530719
Actually I have SEF urls activated.
0
 
LVL 12

Expert Comment

by:Panagiotis S
ID: 36530766
i cant see any page in your web site with the above url tmpl=component
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 
LVL 15

Author Comment

by:gplana
ID: 36530891
I don't understand. This link is not working for you ?: http://www.mediacionyparticipacion.com/index.php?tmpl=component
0
 
LVL 12

Expert Comment

by:Panagiotis S
ID: 36531389
what kind of link is the above?

can i find it through the site?
0
 
LVL 15

Author Comment

by:gplana
ID: 36531500
It's the homepage, but only the sectio npart (the content of the component). So I want to avoid user to be able to access this.
0
 
LVL 12

Expert Comment

by:Panagiotis S
ID: 36531515
how an average user will imagine to write this url?

0
 
LVL 15

Author Comment

by:gplana
ID: 36531796
Don't worry about this. I need a solution because I have detected google has indexed this URL
0
 
LVL 12

Expert Comment

by:Panagiotis S
ID: 36531934
use sh404sef o redirect this url to another
0
 
LVL 15

Accepted Solution

by:
gplana earned 0 total points
ID: 36532706
I found a solution for my own.

I have copied index.php to component.php on the template folder. This doesn't avoid tmpl parameter but makes it doing the same as if it is not present.

0
 
LVL 15

Author Closing Comment

by:gplana
ID: 36555847
I found solution for my own.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This is our step by step to setting up and configuring a Joomla Install on a Windows 2003 Server. This is the perfect solution for an Intranet Website using Joomla. What you need (only use the following versions) : A fresh copy of Joomla http…
Hi, in this article I'm going to teach you how to run your own site, and how to let people in (without IP). I'll talk about and explain each step... :) By the way, everything in this Tutorial is completely free and legal. This article is for …
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question