Solved

Bounce Back and then Denied Send betweeen Exchange 2010 and Chinese Email Server (I believe a TEAMWare Server by Fujitsu)

Posted on 2011-09-13
3
1,228 Views
Last Modified: 2012-05-12
Below is the error.  It looks like the receiving server tried to do a reverse lookup and it failed for some reason.  Haven't received any problems with this domestically and we've been on Exchange 2010 (from Exchange 2003) for about 6 months now.  I'm wondering if that is because most companies don't do reverse lookups in email or is it because of some incompatibility between Exchange and whatever server type their using?  They are in China, could it be the Chinese Great Firewall?  Is there any 3rd party or integrated tool or website to which I can go and test HELO/EHLO lookups to make sure that my server is responding properly to them?



Winmail rejected your message to the following e-mail addresses:

Jerry Huo (huojun@chinesecompany.com)


Winmail gave this error:
refused, 'helo'/'ehlo' hostname(AGCV10k.company.lcl) is not match with the IP(X.X.X.X)


A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.








Diagnostic information for administrators:

Generating server: AGCV10K.company.lcl

huojun@chinesecompany.com
Winmail #554 refused, 'helo'/'ehlo' hostname(AGCV10k.company.lcl) is not match with the IP(X.X.X.X) ##

Original message headers:

Received: from AGCV13K.company.lcl ([fe80::c893:80f1:4d72:fab9]) by
 AGCV10k.company.lcl ([169.254.1.186]) with mapi id 14.01.0323.003; Mon, 12 Sep
 2011 16:15:34 -0700
From: John Smith<john.smith@company-global.com>
To: Jerry Huo <huojun@chinesecompany.com>
Subject: RE: Re: RE: Fw: Devkit8500A -- linux/tools files missing on the CD
Thread-Topic: Re: RE: Fw: Devkit8500A -- linux/tools files missing on the CD
Thread-Index: AQHMZvd6kVdI2g9qh0OhQcBQCTbgqpVKdT6g
Date: Mon, 12 Sep 2011 23:15:33 +0000
Message-ID: <508662CF88940C4CA1A660BA54E9C8C12230FC@agcv13k.company.lcl>
References: <201107221809370621090@chinesecompany.com>,
 <508662CF88940C4CA1A660BA54E9C8C16218@AGCV10k.company.lcl>,
 <201108020851273437626@chinesecompany.com>, <201108021730099849991@chinesecompany.com>
 <201108301729522574516@chinesecompany.com>
In-Reply-To: <201108301729522574516@chinesecompany.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
x-originating-ip: [10.10.4.75]
Content-Type: multipart/mixed;
      boundary="_008_508662CF88940C4CA1A660BA54E9C8C12230FCagcv13kcompanylcl_"
MIME-Version: 1.0
0
Comment
Question by:ChocolateRain
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 4

Accepted Solution

by:
krf1963 earned 500 total points
ID: 36531985
I think you're right - the mail server in China is doing a reverse lookup of your server IP address and rejecting the connection because either it doesn't exist or there is a mismatch between the record and your server name.

You should be able to contact your ISP and ask them to set up the required PTR record (I'm assuming it doesn't exist).

If you want to check this, you can use the tools at www.iptools.com to check - simply do a PTR lookup from the 'DNS lookup' tool.
0
 
LVL 1

Author Comment

by:ChocolateRain
ID: 36532048
Just realized another problem.

Our email domain is 'company-global.com' while our internal domain name is 'company.lcl'.

How can I rectify having an Internet facing server that is in a '.lcl' namespace?  How can they reverse lookup my server when the 'company.lcl' isn't a valid internet facing domain name?
0
 
LVL 4

Assisted Solution

by:krf1963
krf1963 earned 500 total points
ID: 36532299
In Exchange 2010, you can change the HELO message that is sent by the mail server to the publicly visible FQDN. This is done on the properties of the SMTP service.

In the Hub Transport section of the Organization configuration, you should be able to see you connector to the Internet in the 'Send Connectors' tab. In the properties of this connector, you can customize the HELO message.

Hope this helps.
exch.JPG
0

Featured Post

Backup Solution for AWS

Read about how CloudBerry Backup fully integrates your backups with Amazon S3 and Amazon Glacier to provide military-grade encryption and dramatically cut storage costs on any platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question