Solved

KB934016 update fails

Posted on 2011-09-13
5
1,599 Views
Last Modified: 2012-05-12
Im trying to install this hotfix in order to fix VSS errors with our TSM backups.
The installer initially runs then we get error:

Update.exe - Application error
The exception unknown software exception (0xc0000409) occurred in the application at location 0x0106a30b.
Click OK to terminate the program
Click on CANCEL to debug the program

Clicking CANcel doesnt do anything.

Hoping someone else has seen this error. Any help would be appreciated


thanks
0
Comment
Question by:mosaictech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 29

Expert Comment

by:Michael Pfister
ID: 36534907
1) Any problems with other Microsoft (Security) Updates?
2) Check if the update wrote a file named KB934016.log to the C:\WINDOWS directory.
3) Temporarily disable your virus scanner and rerun the update.

0
 

Author Comment

by:mosaictech
ID: 36814943
1) No , no problems with other updates
2) yes, here's the log file:

[KB934016.log]
3.969: ================================================================================
3.969: 2011/09/29 08:40:05.684 (local)
3.969: c:\6bd55e322068cd31e841ee23\update\update.exe (version 6.3.4.1)
3.969: Hotfix started with following command line:
3.969: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
4.782: In Function TestVolatileFlag, line 12013, RegOpenKeyEx failed with error 0x2
4.782: In Function TestVolatileFlag, line 12045, RegOpenKeyEx failed with error 0x2
4.782: DoInstallation: CleanPFR failed: 0x2
4.782: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
4.782: SetProductTypes: InfProductBuildType=BuildType.Sel
4.782: SetAltOsLoaderPath: No section uses DirId 65701; done.
4.797: DoInstallation: FetchSourceURL for c:\6bd55e322068cd31e841ee23\update\update_SP2QFE.inf failed
4.797: LoadFileQueues: UpdSpGetSourceFileLocation for halaacpi.dll failed: 0xe0000102
4.813: BuildCabinetManifest: update.url absent
4.813: Starting AnalyzeComponents
4.813: AnalyzePhaseZero used 0 ticks
4.813: OEM file scan used 0 ticks
7.797: CreateUninstall = 1,Directory = C:\WINDOWS\$NtUninstallKB934016$
7.813: AnalyzePhaseOne: used 3000 ticks
7.813: AnalyzeComponents: Hotpatch analysis disabled; skipping.
7.813: AnalyzeComponents: Hotpatching is disabled.
7.813: FindFirstFile c:\windows\$hf_mig$\*.*
7.969: AnalyzeForBranching: Package required to migrate c:\windows\system32\xolehlp.dll not found
7.969: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\xolehlp.dll not found
8.016: AnalyzeForBranching: Package required to migrate c:\windows\system32\rpcss.dll not found
8.047: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\rpcss.dll not found
8.078: AnalyzeForBranching: Package required to migrate c:\windows\system32\ole32.dll not found
8.188: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ole32.dll not found
8.203: AnalyzeForBranching: Package required to migrate c:\windows\system32\mtxoci.dll not found
8.203: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\mtxoci.dll not found
8.203: AnalyzeForBranching: Package required to migrate c:\windows\system32\mtxclu.dll not found
8.219: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\mtxclu.dll not found
8.219: AnalyzeForBranching: Package required to migrate c:\windows\system32\msdtcuiu.dll not found
8.235: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\msdtcuiu.dll not found
8.313: AnalyzeForBranching: Package required to migrate c:\windows\system32\msdtctm.dll not found
8.360: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\msdtctm.dll not found
8.360: AnalyzeForBranching: Package required to migrate c:\windows\system32\setup\msdtcstp.dll not found
8.360: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\msdtcstp.dll not found
8.375: AnalyzeForBranching: Package required to migrate c:\windows\system32\msdtcprx.dll not found
8.391: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\msdtcprx.dll not found
8.391: AnalyzeForBranching: Package required to migrate c:\windows\system32\msdtclog.dll not found
8.391: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\msdtclog.dll not found
8.391: AnalyzeForBranching: Package required to migrate c:\windows\system32\msdtc.exe not found
8.391: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\msdtc.exe not found
8.407: AnalyzeForBranching: Package required to migrate c:\windows\system32\es.dll not found
8.422: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\es.dll not found
8.500: AnalyzeForBranching used 531 ticks.
8.500: AnalyzePhaseTwo used 0 ticks
8.500: AnalyzePhaseThree used 0 ticks
8.500: AnalyzePhaseFive used 0 ticks
8.500: AnalyzePhaseSix used 0 ticks
8.500: AnalyzeComponents used 3687 ticks
8.500: Downloading 0 files
8.500: bPatchMode = FALSE
8.500: Inventory complete: ReturnStatus=0, 3703 ticks



3) Disabling  virus scanner doesn't help. Same thing happened.



Thanks

0
 
LVL 29

Expert Comment

by:Michael Pfister
ID: 36891906
Running out of ideas. You coud try these things:

- Re-download the hotfix to make sure your first download is not damaged (the wrapper should check this though)

- Unpack the entire hotfix (run hotfix-.exe /x) and start the unpacked update.exe from the target directoy.

- Check if C:\WINDOWS\$NtUninstallKB934016$ exists. If yes, delete it. Then run a chkdsk C: /f on your system (requires a reboot).

0
 

Accepted Solution

by:
mosaictech earned 0 total points
ID: 37076479
thank you for all the suggestions mpfister.
We tried that and unfortunately we still had the same problem.
We ended up opening a ticket with Microsoft.
They installed a debugger and after a lot of work they provided us with a new "update.ver" file which allowed us to successfully install the hotfix.

Nothing come seasy these days

Thanks again
0
 

Author Closing Comment

by:mosaictech
ID: 37098873
Suggestions provided helped us narrow down the issue. ultimately the solution was a new file from hotfix provider (microsoft)
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, I had the need to build a standalone system to run a point-of-sale system. I’m running this on a low-voltage Atom processor, so I wanted a light-weight operating system, but still needed Windows. I chose to use Microsoft Windows Server 200…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question