Solved

Delegate of Outlook 2007 Inbox Cannot Expand Subfolders

Posted on 2011-09-13
11
1,245 Views
Last Modified: 2012-05-12
How can a delegate expand an Inbox subfolders?

A delegate of another's Inbox with full permissions on the Inbox though not the folder owner can only see the contents of the Inbox and it's subfolders. But those subfolders can't be expanded by the delegate.

All mailboxes are on Exchange 2007 and both owner and delegate are using Outlook 2007.
0
Comment
Question by:kelliek
  • 7
  • 2
  • 2
11 Comments
 
LVL 23

Expert Comment

by:Brian Gee
ID: 36533580
You'll need to explicitly add Permissions for the subfolders individually (or provide the delegated user full access to the entire mailbox from Exchange).
0
 

Author Comment

by:kelliek
ID: 36533739
As a test, I added permissions for the first two subfolders in the Inbox. But the delegate couldn't expand those two. I did not set permissions for all the subfolders because there are almost 100 and didn't want to go through all that if it wasn't going to work.

Is the problem that it is all or nothing and I have to set permissions for ALL subfolders before it is going to work for any of them?
0
 
LVL 23

Expert Comment

by:Brian Gee
ID: 36533886
Should only need to set permissions for the folders requiring access. Try closing Outlook, waiting a few seconds, and then relaunching Outlook. See if those subfolders become accessible (that is, can the delegate now see the contents of the subfolders that were provisioned with Editor (or so) permissions.
0
Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

 

Author Comment

by:kelliek
ID: 36536213
The problem is that the two people's accounts are on different servers. The secretary on Exchange 2010 and boss on Exchange 2007. The boss's account was so large that networking couldn't move it from 2007 to 2010 and I wasn't aware of that. Networking is moving the boss's account now but it will take awhile to complete. So I will test giving subfolder permissions and expanding them later today.

Meanwhile, I successfully tested it on selected subfolders between me and a colleague, both of us having accounts on the same server and the same version of Outlook.

I wish there was a faster way to go through all 100+ subfolders and assign permissions other than one by one.
0
 

Author Comment

by:kelliek
ID: 36549883
Me again, the one who can't get a user to expand another user's Inbox.
Both users accounts on Exchange 2010
Both users have Outlook 2007
The admin has been given permission on the boss's Inbox and on many Inbox Subfolders. She also is a delegate of the mailbox and can send email on behalf of the boss.
The Admin has added the boss's mailbox under Account Settings, Email, Exchange, Advanced
So the boss's mailbox appears in the admin's Outlook
There is a plus next to the boss's mailbox (the Inbox doesn't show)
Clicking the plus next to the boss's mailbox doesn't expand the mailbox to even see the Inbox. It says the admin doesn't have rights to do this.
So that must mean that the permission process failed somehow.
The admin swears that the boss gave permission on the Inbox and the top 20 or so subfolders to the admin.
Networking doesn't want to make the admin a member of the boss's mailbox, security you know. And networking says it is just a bandaid. Huh.

What is my next step?
 
0
 

Author Comment

by:kelliek
ID: 36560792
I got the subfolders to appear on the admin's computer.
I had to create a new Outlook profile for the boss, give Delegate access, then set permissions on the mailbox. After that I went through subfolders setting permissions for them.

Creating a new boss profile solved the problem of the admin not being able to expand the mailbox to see the main folders and in-box subfolders. My guess is that the original profile was slightly corrupted by the mailbox move from Exchange 2007 to 2010. The first time networking tried to move the boss's mailbox, it failed because it was so large.
The next time the move was done on the boss's specific mailbox, not programmatically for a large group of users.

However...
The admin is today saying that she can't create sub-folders for the boss, even though I checked create sub-folders. Guess I will double-check. Will be glad when this works!
0
 
LVL 47

Expert Comment

by:apache09
ID: 36577127
From what you have above and what you would like the Delegate to do.....

Delegate access is not really whats required here.
Delegate access is still quite restricted when it comes to Non-Standard folders in a MailBox or SubFolders
Reason being is these sub folders can contain Private items

What this person really need to performs what they are trying to do above
Is FULL Mailbox rights
These rights are applied through Active Directory, not Delegate Access
To do this you will need to add the user to the Mailbox with appropriate permissions
Which SOunds like Full

Once done they can then added the "Boss's" Mailbox to their profile and perform these tasks with out Issues

However, this is Highly unconventional
Should be no reason to give any other member of Staff Full Exchange Access to another User mailbox
Especially the bosses.

Its just asking for trouble

No to mention, the Support Nightmare its going to be when the boss comes to you and tells you your Exchange isnt working because hes missing important emails

Only to find out they have been moved or deleted by the secratery....

0
 

Author Comment

by:kelliek
ID: 36577523
We not give the admin full rights to the boss's mailbox. There is too much risk of breaching privacy and security, though at this point the admin can see just about everything except private appointments.

The admin does need delegate status so she can respond to emails and requests for appointments.

Haven't gotten back to the boss to check permission settings, but am hoping I missed checking subfolders somewhere.
0
 

Accepted Solution

by:
kelliek earned 0 total points
ID: 36717467
Problem was on the Boss's computer. When I change permission settings for the top mailbox level: mailbox - username, I forgot to check Subfolders.
Once I did that and upgraded both of them to Office 2010, everything worked as it should.
Case closed - do I get the 500 points!? :D
0
 
LVL 47

Expert Comment

by:apache09
ID: 37111209
That’s another way you can do it.

Glad you got it sorted.

You can accept your own answer.

However, unfortunately you don’t get points for answering your own questions

Start Answering Other Questions Here or other zones, and you can start building up points.

http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/
0
 

Author Closing Comment

by:kelliek
ID: 37136695
None of the other suggestions worked but mine did.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I didn’t use eM Client for long when I decided to swap to Outlook 2016. The reason for the switch is that it started asking for payment to continue some of its services after one month.   The problems I faced when I didn’t pay were:   I was not …
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now