[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Missing Field for Parameter

Posted on 2011-09-13
4
Medium Priority
?
243 Views
Last Modified: 2012-05-12
Hi there,

It could be just  a very long day but I have created a formula to group records together.  This works out perfectly - all of the data is in the correct areas. But now I would like to use the same formula to as a Parameter but I can't select it from the list of available fields.

I create a new parameter but in the value field I drop down the menu but can't see the field I created to group by.

Sounds so simple but I can't figure our why - any help would be greatly appreciated,

thank you -
cms
0
Comment
Question by:rporter45
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 14

Expert Comment

by:Brook Braswell
ID: 36535976
Have you tried to refresh your data source ?

Database->Verify Database
0
 
LVL 101

Assisted Solution

by:mlmcc
mlmcc earned 240 total points
ID: 36536229
I believe parmeters can only get their data from database fields.

I this a regular Crystal parameter or a Command parameter?
Is it static or dynamic?

mlmcc
0
 
LVL 26

Accepted Solution

by:
Kurt Reinhardt earned 260 total points
ID: 36536237
You can't use formulas as the basis for parameters. If you want to use the result of a formula as a parameter value then you need to add the result into the pick list manually (in a static parameter).

If you're going to use a dynamic parameter, then you'd have to build a business view with an LoV or create a SQL Command object that has the  code for the formula inside of it.
0
 

Author Closing Comment

by:rporter45
ID: 36536362
Hi there,

Mlmcc - you are correct!  rhinok your additional information prompted me to create a parameter that allowed the user to select the group names.  I then went into select expert, chose the formula that I used for the grouping and then added the parameter to the criteria.

All works perfectly now,

Thank you -
cms
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question