Solved

Using VMware converter standalone with USB drive as destination

Posted on 2011-09-13
10
2,310 Views
Last Modified: 2012-05-12
I am using VMware vCentre Converter Standalone for the first time.  My aim is to clone a physical computer as a VM to run on Workstation 7.  However, I am running into problems with the destination - possibly because I am trying to use an external Lacie drive (500GB, connected via USB) as the destination.  Here is the further information.

The source is a powered-on local machine (i.e. I have installed VMWare Converter on the same physical machine as I am converting).  

The destination type is VMWare Workstation 7.0x.  

For the destination, I have selected a Lacie external drive connected via a USB to the powered on (source) computer, because the source computer is not on a network - i.e. the source is a stand-alone computer.

However, when I get to the options summary page I get a warning symbol against the "data to copy", with the message that "the destination file system might not support large files".  Further, the "copy type" has been set to volume-based, with no option to select disk-based copying.  Finally, the "volumes to select" is empty - whether I use basic or advanced.

From my reading of the manual, I note the message: "For hosted destinations that reside on SMB or NFS shares, you must use volume-based cloning".  I don't understand this message, because I don't know what SMB or NSF shares are.

Can anyone help with this?  The specific questions are:

1.  Is it possible to use an external USB drive as the destination?
2.  If yes, does that external drive need to be formatted in a particular way to allow it to be used as a destination?
3.  Is there something else I am missing?

Please note that I do not have access to any of the expensive, corporate VMWare tools such as VMWware server.  We have only VMware Workstation licences, plus the free tools such as VMWare Converter.  

Thank you.

0
Comment
Question by:1104d
  • 5
  • 3
  • 2
10 Comments
 
LVL 4

Accepted Solution

by:
mrbrain646 earned 250 total points
Comment Utility
is vmware workstation installed on the same machine? If so you can goto FIle==Import to import the machine without the converter. Also check your lacie drive to see what file system is formatted with. (NTFS)
You should be able to use an external drive.
0
 
LVL 4

Expert Comment

by:mrbrain646
Comment Utility
0
 
LVL 22

Assisted Solution

by:Luciano Patrão
Luciano Patrão earned 250 total points
Comment Utility
Hi

Is this USB external drive connected to the physical server that you plan to convert?

Because you cannot convert a physical machine with USB external disks connected.

vConverter will get many issues, because it will treat this external disk, as an internal disk.

Why dont you try a remote conversion? Install the vConverter in another machine(laptop maybe), connect that USB to the laptop and choose destination Workstation, then put on that drive.

Or you need to create a Share folder on your network to hold that VM.

SMB
http://www.samba.org/cifs/docs/what-is-smb.html
NFS
http://en.wikipedia.org/wiki/Network_File_System_%28protocol%29

Is the same creating a Share Folder over the network.

How to create a Share Folder
http://www.ehow.com/how_5073394_create-shared-folder.html

Source and destination need to communicate between them. Use IP address to connect source and destination servers, rather than DNS names.

Here is a article that I have written how to convert Windows Servers.
http://www.experts-exchange.com/Software/VMWare/A_3639-VMware-vConverter-P2V-for-Windows-Servers.html

The USB External disc do not need to be a special format, if the Windows can accessed then vConverter will also.

Hope this can help

Jail
0
 

Author Comment

by:1104d
Comment Utility
Thanks mrbrain646 for the suggestion to approach the problem a different way.

Originally I did not have Workstation installed on the source machine, but I have done so now to test whether it works.  I didn't realise that Workstation can be used to import the same physical machines on which they are installed.  

The import looks like it is probably working (I can see a stream of .vmdk files, each of 2GB, being created on the target), but - an hour after starting the process - it is still saying only 1% complete.  At this rate it will take a few days to import!  I will keep the process running and report back when the job is complete.
0
 

Author Comment

by:1104d
Comment Utility
Thanks also Jail - I am looking through your response now ... will probably need a few hours to read through the materials on the links and experiment with setting up a share (as the PCs in the office are not currently on a network).  Will reply in a few hours, when I've given the suggestions a go.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:1104d
Comment Utility
Alas, still haven't managed to get this working - though I haven't yet had a chance to try the options suggested by Jail/BestWay.  

Whatever combination of options I try using Workstation (which correctly sees only the volumes on the source PC, not on the destination drive), the conversion runs successfully for about half an hour (creating a set of files on the target drive).  But then eventually it crashes with the error message "Failed to take snapshot of a source volume.  Possible causes include not having any NTFS volumes on Windows XP or Windows 2003 source systems ....".

I have worked through all the solutions  I can find on the web (including making sure that the Volume Shadow Copy etc services are running), checking disks, etc - but none will fix the problem.  It always runs for a while, then crashes,  By the way, the operating system is Windows 7 Ultimate, not XP or 2003.

Could the problem be something to do with the fact that the source computer is a RAID disk with several volumes - and one of those volumes is an OEM partition with an unspecified file system type?

Tomorrow I will try again (incl trying to set up a network share) .... any suggestions in the meanwhile appreciated.

Thanks again.
0
 
LVL 22

Expert Comment

by:Luciano Patrão
Comment Utility
Hi

For Windows 7, please use the last vConverter version.

And yes the SO partition that 2008 and Windows 7 use, can get issues when converting this.

That error you find is fix on the vConverter 4.3 version.

What is the vConverter version that you are working?

Using also cold clone conversion you can bypass this issues with the System Reserved Partitions.

Jail
0
 
LVL 4

Expert Comment

by:mrbrain646
Comment Utility
Do you have a screen saver turn on? or power saver options that hibernates the computer?
I would try a different external drive if possible and a different USB port.
0
 

Author Comment

by:1104d
Comment Utility
Guys - Thanks for the fabulous answers!  

All of the info above was incredibly useful - including BestWay/Jail's very detailed info on using vConverter across a network, as well as mrbrain646's suggestions on using Workstation directly.

Although I still haven't got the clone to succeed this is because I ran out of time (my colleague needed his source PC back today before I could progress much further with the tests, and I won't get it back for a few days).

However, I wanted to accept both the above solutions and award the points, because both sets of answers exactly answered my original question.  I look forward to cloning lots more physical PCs using this information!

Thanks again very much to both of you!  Really appreciated it.

PS - BestWay/Jail - Yes it was the latest 4.3 version of vConverter. I think you're right about the partition and hence the need to do the cold clone instead - will try that next week.
0
 

Author Closing Comment

by:1104d
Comment Utility
Great answers, really appreciated the info!
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
VMware Vcenter Inventory Service problem 21 82
Hyper-V VM migration fails 14 48
Vmware Workstation 12 3 37
Vmware 5.5 3 22
It Is not possible to enable LLDP in vSwitch(at least is not supported by VMware), so in this article we will enable this, and also go trough how to enabled CDP and how to get this information in vSwitches and also in vDS.
David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
In this video tutorial I show you the main steps to install and configure  a VMware ESXi6.0 server. The video has my comments as text on the screen and you can pause anytime when needed. Hope this will be helpful. Verify that your hardware and BIO…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now