Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 305
  • Last Modified:

flash problem

Hi Experts,

I trying to add a banner image to a flash banner ad rotator on a website.  When I edit the textVar file (apparently referenced in the params) my changes don't have any effect on the banner ad images.  It's as if the swf file isn't reading the txtVar.txt file.

I want to add a 3rd image to the rotation but the aboutPrin.swf seems to ignore my textVar.txt file edits.

I've attached the files so you can see what I mean.

Can you help me figure this out? Unfortunately I don't have access to the original aboutPrin.swf to edit.

thanks

HNM

 flash-files.zip
<div id="imageHead">
                        	  <script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','497','height','114','src','aboutPrin?folder=images/weddings/superior','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','wmode','transparent','movie','aboutPrin?folder=images/weddings/superior' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="497" height="114">
<param name="movie" value="aboutPrin.swf?folder=images/weddings/superior" />
                                <param name="quality" value="high" />
                                <param name="wmode" value="transparent" />
                                <embed src="aboutPrin.swf?folder=images/weddings/superior" width="497" height="114" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" wmode="transparent"></embed>
                      	    </object>
                        	</noscript></div>

Open in new window

0
HelpNearMe
Asked:
HelpNearMe
  • 5
1 Solution
 
HelpNearMeAuthor Commented:
no flash experts out there?
0
 
Jen0910Commented:
2 things may be an issue:

You have an embed em pram tag, both looking for the swf file within images/weddings/superior, but the files you uploaded are weddings/superior with no image folder and no flash file within the superior folder. set the directory up to match your embed and pram, or reset your embed to match your directory.

example:
<param name="movie" value="aboutPrin.swf?folder=images/weddings/superior" />

Open in new window



according to what you uploaded should be

<param name="movie" value="aboutPrin.swf?folder=weddings/superior" />
...
<embed src="aboutPrin.swf?folder=images/weddings/superior" width="497"...
...
<embed src="aboutPrin.swf?folder=weddings/superior" width="497"...
(move your swf into that "superior" folder)

Open in new window



The other thing, without access to the aboutPrin.swf we have no way of knowing where it is looking for your text document (if that is indeed your problem). Try a decompiler and see if that will tell you the path where it is looking to find the txtVar.txt file. If it isnt exactly where the SWF is looking, nothing is going to happen.
0
 
HelpNearMeAuthor Commented:
Jen0910
The paths are correct on the live site, there is a parent folder called images which contains the wedding etc folders.  I found an online decompiler for aboutPrin.swf and the results are attached. here is the link: http://www.showmycode.com/?e77aac247744ee51c8d2407cf1bfb631

see any reason why this shouldn't work?

Thanks

HNM
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
HelpNearMeAuthor Commented:
If I add a new image to textVars.txt it won't get picked up by flash.  In fact I can completely corrupt the file and the flash presentation keeps on going without a problem.  It's like the actual textVars.txt is being picked up somewhere else.
0
 
HelpNearMeAuthor Commented:
I just downloaded all of the site files and I'm searching for another instance of textVars somewhere else.
0
 
HelpNearMeAuthor Commented:
Nevermind....

Internet Explorer strikes again.  Works fine in Chrome, and every other browser except mine

Thanks anyway

HNM
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now