Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1530
  • Last Modified:

Disabling the "Windows Server Post-Setup Security Updates" Screen

I am trying to completely disable the "Windows Server Post-Setup Security Updates" Screen during my Windows 2003 R2 w/ SP2 operating system deployment via System Center Configuration Manager.

I followed the advice from the post at http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_25974353.html#a36536497

However the advice listed did not work.

I ran the following command during my os deployment and the registry key was indeed properly inserted.

REG ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\ServerOOBE\SecurityOOBE /v DontLaunchSecurityOOBE /t REG_DWORD /d 0

 HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\ServerOOBE\SecurityOOBE
However, when the OS deployment was finished, I could not remotely access the server, so I figured the "Windows Server Post-Setup Security Updates" nag screen was up and all communication to the server was still blocked due to that fact.

I was correct with my assumption because when I logged into the freshly imaged server, the "Windows Server Post-Setup Security Updates" nag screen was up, even though the registry key specified at http://technet.microsoft.com/de-de/library/cc757061%28WS.10%29.aspx was present and set correctly.

"Windows Server Post-Setup Security Updates" Screen
I need to run some kind of script during operating system deployment that will prevent this "Windows Server Post-Setup Security Updates" nag screen from ever functioning.

Anyone have any idea of what the real fix is for this?
0
ACECORP
Asked:
ACECORP
  • 2
1 Solution
 
GovvyCommented:
Set this in registry:

DontLaunchSecurityOOBE (DWORD) in:
HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Windows \Current Version \ServerOOBE \SecurityOOBE

This key does not exist by default.

The key can exist or not exist. If the key exists, Post-Setup Security Updates does not display. The numerical value of this setting is irrelevant.
 

0
 
ACECORPAuthor Commented:
I already did that. It doesn't work as described in detail in my posting above.
0
 
GovvyCommented:
Sorry in that case add this to the unattend script:

ServerWelcome=No
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now