Solved

a question with BGP loopback neighbor establishement

Posted on 2011-09-14
6
1,245 Views
Last Modified: 2012-05-12
hello,

i have 2 routers on GNS3, i want to configure BGP based on the loopback of each router, but it never comes to Established status, it is stuck in "Active" here is my topology:


                               R1 =================
                                                                   //================== R2

Config:

R1:

R1#show run
Building configuration...

Current configuration : 1048 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!        
interface Serial0/0
 ip address 192.168.12.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 1
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 192.168.12.0
 neighbor 2.2.2.2 remote-as 2
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback1
 no auto-summary
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!        
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R1#

=================================================================


R2:

R2#show run
Building configuration...

Current configuration : 1048 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.0
!        
interface Serial0/0
 ip address 192.168.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 2
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 network 192.168.12.0
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback1
 no auto-summary
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!        
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R2#

0
Comment
Question by:zakar1a
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 25

Expert Comment

by:Ken Boone
ID: 36536915
The problem is that either router does not have a route to the other's BGP loopback address.  You have to be able to at least reach your BGP peer and right now you cannot.  Add a static route on each router to reach the other's BGP peer ip address and then it should come up.
0
 
LVL 7

Author Comment

by:zakar1a
ID: 36536940
i got this from debug:


*Mar  1 01:24:06.947: BGP: 2.2.2.2 active open failed - no route to peer, open active delayed 26593ms (35000ms max, 28% jitter)
0
 
LVL 25

Accepted Solution

by:
Ken Boone earned 500 total points
ID: 36536995
That is exactly what I mean:

On rtr 1 you need:
ip route 2.2.2.2 255.255.255.0 192.168.12.2

On rtr 2 you need:
ip route 1.1.1.1 255.255.255.0 192.168.12.1

Then each router will have a route to the other's loopback and then it will come up.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 7

Author Comment

by:zakar1a
ID: 36537069
you meant :

ip route 2.2.2.2 255.255.255.255 192.168.12.2
ip route 1.1.1.1 255.255.255.255 192.168.12.1

right?
0
 
LVL 25

Expert Comment

by:Ken Boone
ID: 36537113
yea correct.
0
 
LVL 7

Author Closing Comment

by:zakar1a
ID: 36537140
thank you
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SonicWall Max Connection Setting 7 39
Recovering ASA 5505 vpn config from flash card? 7 35
Advice on router and switch 25 40
IP Jumping 6 18
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question