• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 413
  • Last Modified:

Asterisk Not Starting Correctly

I've just done new install - asterisk 1.8.xxx + Ubuntu 11.xxx, I'm trying to run the AMI so I can connect with a switchboard, here's my manager.conf:
[general]
enabled = yes
port = 5038
bindaddr = 127.0.0.1
[admin]
secret = xxxx
deny = 0.0.0.0/0.0.0.0
permit = 127.0.0.1/255.255.255.0
read = all
write = all
#include "manager.d/*.conf"
The switchboard can't connect, and when I run this line:
sudo netstat -lnp | grep 5038 nothing is listening. Where am I going wrong?
But when I run this l
0
Silas2
Asked:
Silas2
  • 4
  • 2
  • 2
  • +1
3 Solutions
 
Ron MalmsteadInformation Services ManagerCommented:
Firewall?
0
 
Silas2Author Commented:
I'm pretty sure there is no firewall anywhere (its on a sort of DMZ, only asterisk box->ISP, nothing else)
0
 
Ron MalmsteadInformation Services ManagerCommented:
No I meant Ubuntu firewall.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
José MéndezCommented:
Did you reset the server?
0
 
FishMongerCommented:
Are you sure your setting of read and write are correct?  The wiki docs don't show that 'all' is a valid setting/value.

Try changing them to:
read = system,call,log,verbose,command,agent,user,originate
write = system,call,log,verbose,command,agent,user,originate
0
 
FishMongerCommented:
Are making the AMI connection directly from the asterisk server, or from another system on your network?  If it's from another system, then your should/need to specify your network address instead of your loopback address.
0
 
Silas2Author Commented:
xuserx2000: Definately, IPtables blank, new install, and I didn't make any rules.
FishMonger: Swapped the 'all'' for the explicit values
re loopback. Its all one server, its really the simplest it could be, ISP->asterisk/ubuntu box->ISP, the AMI is being (or not being) accessed by fop2 resident on the asterisk box, so I guess that 127.0.0.1 is right, isn't it?
0
 
Silas2Author Commented:
+ willlywilburwonka, yes did a reboot (or three), still no:
sudo netstat -lnp | grep 5038
0
 
Silas2Author Commented:
Ah, I think I found it. Does that line, which was in before
#include "manager.d/*.conf"
the hash is not a comment, so it is maybe looking in that location for manager info overriding the stuff in this file? I took it out and is now listening on 5038.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now