Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 268
  • Last Modified:

Inserting data into mysql using php

Hi,
I'm inserting  data into a mysql table as below and it works.
However when I add 2 more Null columns to the end of the table, the procedure doesn't work.
I have no problem querying the table with the extra columns added to the query.
Hope you can help.
Thanks

$query = "INSERT INTO competition  (dates,day,type,format,fee,) VALUES
            		
			('".$dates."', '".$day."', '".$type."', '".$format."', '".$fee."')";
  $result = $conn->query($query);

Open in new window

0
encodeme
Asked:
encodeme
  • 3
  • 3
1 Solution
 
Garry GlendownConsulting and Network/Security SpecialistCommented:
Have you tried the same syntax in the MySQL console?
Have you tried configuring a default value for the new columns, does that correct the behavior?
0
 
encodemeAuthor Commented:
Hi Garry,
I'm struggling on how to write the query to work in the MYSQL console.... or it doesn't work.

I tried this

INSERT INTO competition  (dates,day,type,format,fee,) VALUES
            		
			(['2011-09-09'], ['sunday'], ['red'], ['green'], ['10'])"

Open in new window

0
 
encodemeAuthor Commented:
It's to do with the 2 new columns.
If i create a variable, give it a value, change the insert to include the new columns it works.

The column format is as below...I'm sure I'm doing something silly.


2011-09-14-213305.jpg
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Andrew DerseIT ManagerCommented:
encodeme try this query syntax instead:

 
$query = "INSERT INTO competition  (dates,day,type,format,fee) VALUES
            		
			('$dates', '$day', '$type', '$format', '$fee')";
  $result = $conn->query($query);

Open in new window


For starters, you had an extra comma at the end of line 1 after fee...that needs to be removed.

Then, you need to only have 1 set of quotes or single quotes around your variables.  Numeric variables do not need quotes around them...all of the variables are seperated by commas.

Try that code I modified for you and see if it that helps.
0
 
Andrew DerseIT ManagerCommented:
Also, you don't need to have your default as NULL as you have the NULL checkbox checked already...if you don't insert any information it's already NULL so remove your default = NULL from the draw column, but make sure you keep the NULL checkbox checked.  Do the same with your other column.
0
 
encodemeAuthor Commented:
Brilliant .. I'm not sure which bit did it but removing the comma and quotations marks made it work.
Curiously in Mysql ..unless I'm wrong, when you change the default field to none, if the Null is ticked, the default fiield is re-set to Null.
many thanks for the help ..enjoy the points :)
0
 
Andrew DerseIT ManagerCommented:
Glad to hear it worked ;)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now