Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

SQL "Starting up database 'ReportServerTempDB'. message

Posted on 2011-09-14
7
Medium Priority
?
2,009 Views
Last Modified: 2012-05-12
Let me start out by saying I know nothing about SQL Server. I am running SQL 2008 Express for our acounting software and I'm seeing a LOT of messages ( sometimes every few seconds)  in the application log for reporting services, this being one of them:
"Starting up database 'ReportServerTempDB'.

 Is there something I can do to get rid of these, or, more importantly, would this have any affect on performace, because of some configuration setting that is causing the Reporting server to do things more regularly than needed?

Thanks,
CJA
0
Comment
Question by:cja-tech-guy
  • 3
  • 3
7 Comments
 
LVL 8

Accepted Solution

by:
venk_r earned 1000 total points
ID: 36540034
Reporting Services automatically "wakes up" every ten minutes or so to check various things. To do this check, it has to query it's databases. When it queries the database, it has to open the database, which results in the log entry you are seeing.

The "wake up" behavior of RS is normal behavior. The need to open the database is a result of the default settings of SQL Express that all databases have Autoclose turned on, so when there is no activity in a database, it is closed.

As I said, this is normal behavior, if the log entries really bug you, you have to Set the Autoclose property on the RS databases to False, this way they won't close, and thus not need to be opened, which causes the Log Entry.

0
 
LVL 5

Assisted Solution

by:VENKAT KOKULLA
VENKAT KOKULLA earned 1000 total points
ID: 36542631
Please keep the Auto close option "false" if you dont want to see that message again and again.

To make it False, Go to Database properties--> Options-->then you can see 'Auto Close' option in middle of the window, select it as False.

Might it will help you.

--Venkat
0
 

Author Comment

by:cja-tech-guy
ID: 36542925
I checked the settings in Options and "Auto Close" was already set to "false".  Any other things I should check?  I also noticed the message in the log after hours when no one is using the database.  Only the back up runs over night.

Thanks,

CJA
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 8

Expert Comment

by:venk_r
ID: 36542977
If I were you I wouldnt worry.Its just a regular check by the reporting service engine.It shouldn't impact your performance at all.
0
 

Author Comment

by:cja-tech-guy
ID: 36543080
OK. Thanks
0
 

Author Comment

by:cja-tech-guy
ID: 36543098
I was looking at the wrong database.  When I checked the reportservertempdb, it was set to "true".  Since you are telling me it is a normal process and that it won't affect performance, I will leave it alone.

CJA
0
 
LVL 8

Expert Comment

by:venk_r
ID: 36543129
Well, Since you said go ahead and set it to false. It isnt going to benefit anything with setting it to true truely speaking.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
I have a large data set and a SSIS package. How can I load this file in multi threading?
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Via a live example, show how to extract information from SQL Server on Database, Connection and Server properties

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question