Solved

Outlook 2010 - Send on Behalf only works when selecting senders from the Global Address List...Why doesn't it work when sending from AutoComplete that was from the GAL?

Posted on 2011-09-14
10
5,150 Views
Last Modified: 2013-06-06
I've followed the steps exactly for setting Delegate access in Outlook 2010 (Send on Behalf access was set up from Outlook, not the Server). The users cannot ‘Send on Behalf’ unless they select the sender’s name from the Global Address List. They have to click 'From' and then click 'Other Email Address...' to go to the GAL. If you try sending on behalf by selecting a name in the ‘From’ drop down box (because it was already sent form that address) it will fail with a non-deliverable error message. This even fails if the name is originally from the GAL. Our organization is using Exchange Server 2007 SP3 and the Domain Controllers are Windows Server 2008 R2 (Server 2003 Forrest Functional Level). All of the affected users with the Send on Behalf problem are using Outlook 2010. Would upgrading Office to SP1 or migrating to Exchange Server 2010 SP1 resolve this issue?
Perhaps on a related note; when adding a contact to Outlook from the Global Address Book, it will disappear from Outlook Contacts after about 10-15 seconds after clicking Save & Close to add it to the Contacts. The work around I found was to click File, Save-As, and save the VCF to my documents then double click the VCF file to add it to Outlook Contacts that way it doesn't disappear. Any help would be appreciated. Thanks. Please Advise.
 Send_on_Behalf_From
0
Comment
Question by:USOE
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 37

Expert Comment

by:Jamie McKillop
ID: 36539909
Hello,

In order the use Send on Behalf, the from field must contain the object resolved to the GAL. You cannot simply use the SMTP address as your screenshot shows. You can type the SMTP address instead of choosing the object from the GAL but you must press Alt+K to resovle the SMTP address to the GAL before sending.

JJ
0
 

Author Comment

by:USOE
ID: 36574088
I understand that the object does need to be resolved from the GAL as that is the only way it works now. My problem is that the additional email address that is shown in the drop drown in the image above was resolved from the GAL and then is is basically a history of previous addresses sent "from" that is shown. Selecting this address (that was previously resolved from GAL) fails every time. When the organization had Outlook 2007 this worked. Now with Outlook 2010 they have to select Other email Address and then type or select a name form the GAL. I even upgraded to Office 2010 SP1 and it still did not correct the issue. Any other ideas?
0
 
LVL 37

Expert Comment

by:Jamie McKillop
ID: 36574396
If it is in SMTP format, it is not resolved to the GAL. Once it is resolved to the GAL, it will change to the Display Name and be underlined.

JJ
0
Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

 

Author Comment

by:USOE
ID: 36599876
Thanks for the clarification. Therefore, how you do you get the GAL resolved Display Name to show instead of the SMTP address in the From field when composing a new message in Outlook 2010. Outlook 2007 had a blank line that would display the Display name of the sender, but Outlook 2010 displays the senders SMTP email address in the From field. Any suggestions on how to change those settings in Outlook 2010 would be great.
0
 
LVL 21

Accepted Solution

by:
Hendrik Wiese earned 500 total points
ID: 36715535
Try the following:

1. Create a new mail
2. Now type in the email address that you are trying to send from
3. As soon as the auto complete appears and highlights the name hit Delete on your keyboard to delete the current entry.
4. Now close outlook and open it up again.
5. Now create a new mail again
6. Type the first name of the user and press the Ctrl + K buttons on your keyboard
7. This will create a new auto complete entry.
8. Now try to send an email again and see if you still run into the same problem.

Hope this helps!!
0
 

Expert Comment

by:crp0499
ID: 36719289
I have the same issue and can confirm that Message ID: 36715535 does not resolve the issue.
0
 
LVL 47

Expert Comment

by:apache09
ID: 36940472
Without knowing what access you gave the Delegates.
They should have Full access (Editor) Permissions on Calendar and or Mailbox to send on behalf

Alternativley the easiest way to set this up is via Active Directory
Open the AD account you want the users to send on behalf of
Open the Properties and go to Exchange Advanced
Add the user(s) and give the full Mailbox rights

 
0
 

Author Closing Comment

by:USOE
ID: 36949163
Wow, I can't believe it actually worked and was so simple. Thank you.
0
 

Expert Comment

by:Cyb3tT3ch
ID: 38118226
This is a non-working solution. It still presents the problem of, once you have selected the user to send from, provided you have the correct permissions to do so, it only ever allows you to send as that user once, and then the cached address in the from list no longer works. The only way to be able to send as that user again is to delete the cached address from the list, and pick it again from the GAL or another contact list. HendrikWiese should not have been given credit for this. It's simply not good enough. His work around is a temporary one, which essentially brings the problem full circle to where it was to begin with.

Bearing in mind this seems to be an Outlook 2010 issue.

So, what else you got as a solution mate?
0
 
LVL 3

Expert Comment

by:TGB01
ID: 39225081
Did anyone try it with reapplying the full access / sent on behalf rights on the mailbox ?
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

PHP contact form that lets the user to contact the company through email contact form. A button is fixed at the bottom of site, on clicking a new window will open where a user can send the email.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question