Solved

rpcping returns Error 87 : The parameter is incorrect

Posted on 2011-09-14
7
1,328 Views
Last Modified: 2013-02-15
I cannot get rpc over http to work. Client is Outlook 2007 connecting to Exchange 2007.
I am using self signed certificates. I have installed the CA certificate on the client.
If I connect to https://mail......org/owa I can login to OWA without getting a certificate warning.

In the Outlook Exchange account I've entered the internal server name in the
Microsoft Exchange Server box. In "more settings" activated
"connect to microsoft ... http" and in the proxy settings I
set URL to https://mail....org. Authentication is set to Basic

If I try to connect to the Exchange server Outlook shows the
...you must be connected/online to complete this operation... error.
I tried outlook /rpcdiag.
The connection status shows directory status connecting.
After entering my credentials I immediately get the ... you must be
connected ... error. The line is removed from the connection
status window. No more output there.

I tried to diagnose with rpcping.

this is the output if i start rpcping on the exchange server:
C:\>RpcPing -t ncacn_http -s hermes.oxxxxxxxo.org -o RpcProxy=mail.oxxxxxxxo.org -P "chris,oxxxxxxxo,yyyyyy" -H 1 -F 3 -a connect -u 10 -v 3 -e 6001 -v 3 -E
RPCPing, Version 6.0. Copyright (C) Microsoft Corporation, 2002-2006
 Da Sie die Option "Echo only" (-E) für den RPC/HTTP-Proxy angegeben haben, wird
 der angegebene Endpunkt/die angegebene Schnittstelle ignoriert, da keine Aufruf
e den RPC/HTTP-Server erreichen.
 RPCPinging für Proxyserver ?????????gt=C:\Windo????????????????Q???ce wird mit
Echoanforderungspaket ausgeführt.
 Die Richtlinie für automatische Anmeldung wird auf hoch festgelegt.
 Aufruf von WinHttpSetCredentials für Zielserver
 Ping wird an Server gesendet.
 Empfangene Antwort vom Server: 200
 Ping erfolgreich abgeschlossen in 109 ms

Open in new window

the above line says "ping successfull with 109ms"

this is the output on the domain controller (the DC is on the
same LAN as the exchange svr).

C:\>RpcPing -t ncacn_http -s hermes.oxxxxxxxo.org -o RpcProxy=mail.oxxxxxxxo.org -P "chris,oxxxxxxxo,yyyyyy" -H 1 -F 3 -a connect -u 10 -v 3 -e 6001 -v 3 -E
RPCPing v6.0. Copyright (C) Microsoft Corporation, 2002-2006
 Since you have specified the RPC/HTTP proxy echo only option (-E), the endpoint/interface you have specified will be ignored as no cal
ls will reach the RPC/HTTP server
 RPCPing set Activity ID:  {e0dce2a1-1af5-42b4-ba3f-2fba573ebc52}
 RPCPinging proxy server mail.oxxxxxxxo.org with Echo Request Packet
 Setting autologon policy to high
 WinHttpSetCredentials for target server called
 Error 87 : The parameter is incorrect.
 returned in WinHttpSetCredentials
 Ping failed

Open in new window


Another thing that bothers me.
If I open https://mail...org/rpc in my browser. I get the blank page
after entering my credentials.
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>
<BODY></BODY></HTML>

Some tutorials decribe that the /rpc url should show a read access denied page
and only the /rpc/rpcproxy.dll URL should show the blank page.
I am not sure if this is valid for exhange 2007 / iis7 any more.

Any hints what wrong with my configuration?
What changes are needed to get rpc over http to work for Outlook?
0
Comment
Question by:nera2001
  • 3
  • 2
7 Comments
 
LVL 7

Expert Comment

by:manu4u
ID: 36540182
Whats your client OS?
Did you try from different OSs? ... Same error?

If it is only from Win 7, do a complete Re-install and then do update all Service packs and patches .. Then create a new Outlook profile, just follow the below URL to create the profile .

http://support.sherweb.com/Faqs/Show/how-to-configure-outlook-2007-exchange-2010 
0
 
LVL 7

Expert Comment

by:manu4u
ID: 36540199
If that doesn't solve the problem, try disabling IPV6 , Heres how to

http://support.microsoft.com/kb/929852/en-us 
0
 

Author Comment

by:nera2001
ID: 36540897
So far I've tested with 2 Windows 7 PCs. One of them had IPV6 disabled. Did not make any difference.
Or did you mean disable it on the server side?

I will test with Windows XP and O2003 today.
0
 

Accepted Solution

by:
nera2001 earned 0 total points
ID: 36552181
Got it working today.

I have connected my Windows 7 PCs to the company network via VPN.
Then I could set up the exchange account with http proxy config.
Everything ok.

Suprisingly this also continues to work after I disconnect the VPN.

So no updates and SPs needed to get this running. IPV6 was no problem either.
0
 
LVL 7

Expert Comment

by:manu4u
ID: 36552819
Glad you got it fixed ..... :)
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Exchange Report - Search All Mailboxes that contain specific SMTP Alias 3 35
Exchange 2010 SP1 to SP3 + RU16 8 44
Exchange 2013 certificate 8 35
Windows 7 Professional 6 57
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
Many people use more than one email account and so it becomes difficult for them to manage them when they use separate accounts,  so, in this article, I have shared an easy way to add Other Mail Accounts in your Google Inbox. It helps to combine all…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question