Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

question on setting up ssh connection on a router

Posted on 2011-09-14
1
355 Views
Last Modified: 2012-05-12
Hi , i am trying to set up ssh on my router and access it from putty.exe

here is part of the config i am using as a template

Username root password quazitron
enable secret jha12wsii
aaa new-model
hostname abc
clock timezone GMT 0
ip routing
ip domain-name abc
ip name-server 172.20.3.21
ip subnet-zero
no ip source-route
no ip http server
no ip http secure-server
ip classless

crypto key generate rsa

2048


interface Vlan100
 description --- Infrastructure ---
 ip address 172.26.102.238 255.255.255.192


router eigrp 100
passive-interface default
no passive-interface Vlan101
network 172.19.26.0 0.0.0.255
network 172.19.30.0 0.0.0.255
no auto-summary


int range fa0/1 - 46
description --- Clients ---
switchport mode access
switchport access vlan 100
spanning-tree portfast
 switchport mode access
 switchport port-security maximum 2
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 storm-control broadcast level 2.00
 spanning-tree portfast
 spanning-tree bpduguard enable


interface GigabitEthernet0/1
 description --- Uplink
 switchport trunk encapsulation dot1q
 switchport mode trunk


ip route 0.0.0.0 0.0.0.0 172.26.102.254 name ---->r1


line con 0
 exec-timeout 35700 0
 logging synchronous
line vty 0 4
 exec-timeout 35700 0
 logging synchronous
 transport input ssh
 transport output ssh
line vty 5 15
 exec-timeout 35700 0
 logging synchronous
 transport input ssh
 transport output ssh
!

ip access-list standard SNMP
 permit 172.18.193.30
 permit 172.20.9.50
 permit 172.20.2.36
 permit 172.24.1.30
 permit 172.21.1.95
 permit 172.20.1.87
 permit 172.20.1.86
 deny   any log

snmp-server community VvVaSDD5fZQqD6MR8CZPBY8wjMSJ3UN RO SNMP


how do i enter this 2048 value ????
0
Comment
Question by:c_hockland
1 Comment
 
LVL 9

Accepted Solution

by:
parparov earned 500 total points
ID: 36539975
When you request the key generation:
crypto key generate rsa

Open in new window

You will be prompted for the key length:
How many bits in the modulus[512]?

Open in new window

There you enter 2048 (or template does).
Please note that generating 2048-bit key may take quite some time, according to this doc:
http://www.cisco.com/en/US/docs/ios/12_2t/12_2t8/feature/guide/ftmltkey.html
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

791 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question