• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1529
  • Last Modified:



I have samba 3.0 "integrated" with windows domain accounts. Users can access samba shares when logging to a windows machine with their domain username and password.

Everything is working well except when I add a new user to Active Directory. This new can access only one samba share!! All others when I try to map new network drive report :

 check_ntlm_password:  Authentication for user [test] -> [test] FAILED with error NT_STATUS_NO_SUCH_USER
  • 2
1 Solution
SimpleJAuthor Commented:
I have tried to authenticate user to samba:

wbinfo -a 'DOMAIN+test%testuserpass'

it returns success but the user still can`t access the share.

Is there any other way to manually authenticate a user or maybe to "refresh" samba user db, ... ?
SimpleJAuthor Commented:
after researching I found out that sid2uid is the problem. It can not assign new uid to user. Can I manually authenticate user:

Samba version is 3.0.24 therefore
wbinfo --set-authenticate-user

is not a possibillity.
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now