Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Event ID 13042 self update on an IIS Server

Posted on 2011-09-15
5
Medium Priority
?
1,243 Views
Last Modified: 2012-05-12
I have been trying to figure out how to resolve this issue for quite some time now and it's time to call in some help, has anyone dealt with this error before.  Running on Windows Server 2003.  Basic Setup.  Server not running other services.

Event Type: Error
Event Source: Windows Server Update Services
Event Category: Clients
Event ID: 13042
Date: 28/03/2011
Time: 04:08:24
User: N/A
Computer: IISSERVER
Description:
Self-update is not working.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
Comment
Question by:IT_User
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 10

Expert Comment

by:gaurav05
ID: 36542237
Hi,

try this

1.) Open IIS Manager
2.) Make sure the Selfupdate virtual directory has Anonymous authentication enabled and "Require SSL" should be unchecked.
3.) Make sure the Default Web site has Anonymous authentication enabled and "Require SSL" should be unchecked.
4.) Remove the SSL (HTTPS) site binding for the Default Web Site.
5.) Stop and start the Default Web site.

feel free to discus.
0
 
LVL 10

Expert Comment

by:gaurav05
ID: 36542248
Also check this

The fundamental issue here is that  you appear to have installed Windows Sharepoint Services on PORT 80, which is blocking the ability of the WSUS Health Monitoring service to access the /selfupdate v-dir on the "Default Web Site".

You need to configure WSS to =Not Manage= the WSUS resources in the Default Web Site, which include /selfupdate, /wutrack.bin, and /iuident.cab. The co-existence requirements of Windows Sharepoint Services and Windows Server Update Services  have been discussed incessantly over the past five years and a simple web search on "WSUS" and "Sharepoint" should turn up dozens of threads all documenting the configuration requirements for WSS to permit WSUS co-existence.

I'm also quite curious that you appear to have a /clientwebservice v-dir in the Default Web Site on a Win2008R2 system, given that the /clientwebservice v-dir has not been required in the Default Web Site since WSUS v3 was released -- but this is merely a curiosity, it has no bearing on the functioning, or lack thereof, of the WSUS environment.
0
 

Author Comment

by:IT_User
ID: 36542295
4.) Remove the SSL (HTTPS) site binding for the Default Web Site.

Unsure as to how to do this, new to IIS so learning on the job!

5.) Stop and start the Default Web site.

Will this interfere with any of the other websites hosted on this server - have tutorenterprise, helpdesk, Intranet and our website?

Unfortunately all of this software was installed by a former IT manager, so reasons for the current config are a mystery.

My system is running on Windows Server 2003.  We are currently running WSUS V3 SP1.  Does this mean that the clientwebservice v-dir should no longer be required?  is this purely utilised by WSUS?
0
 

Author Comment

by:IT_User
ID: 36542301
Sorry, also - how do I configure WSS to =Not Manage= the WSUS resources in the Default Web Site, which include /selfupdate, /wutrack.bin, and /iuident.cab
0
 
LVL 47

Accepted Solution

by:
Donald Stewart earned 2000 total points
ID: 36543414
Verifying WSUS Server Settings

http://technet.microsoft.com/en-us/library/cc708545%28WS.10%29.aspx

Then go over

Issues with Client Self-Update

http://technet.microsoft.com/en-us/library/cc720439%28WS.10%29.aspx


13042 self update error is almost always an issue with selfupdate virtual directory

To ensure that the self-update tree is working properly, first make sure there is a Web site set up on port 80 of the WSUS server. After that you should run the WSUS script that ensures a proper configuration of self-update on port 80. Open a command window on the WSUS server and type the following:

cscript WSUSInstallDirectory\setup\installselfupdateonport80.vbs

Note: Even if your WSUS is on port 8530, there MUST also be a selfupdate virtual directory on port 80
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question