Problem receiving emails from AOL

I have this issue with a user who uses AOL to email me, I do not have this issue with any other person. When they email us they get the following rejection email:


Deferred: Connection timed out with mail.xxx.com.
Message could not be delivered for 3 hours
Message will be deleted from queue

The exchange server was never offline for 3 hours

Any ideas?
htabbachAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

scriven_jCommented:
Timeouts like this are usually a sign of some antispam product that is delaying receipt.

Particularly see problems like this with Yahoo and AOL accounts.

What antispam solution is there between you and the person (both on Exchange and on your mailhost?)
0
htabbachAuthor Commented:
I do not know what they use on their end but we use GFIMailEssential
0
scriven_jCommented:
Ideally you want a copy of the deferred message so you can look at the header (post it here if you can) so you can figure out which mail server is actually causing the delay.

With delays, it is actually the sender that really needs to do the troubleshooting (i.e. report it to AOL) but there is some checking you can do your end.

For instance you can turn on SMTP logging on Exchange and GFI and use that to trace the messages.

You can also use SMTPDIAG to help you troubleshoot mailflow issues.

http://www.microsoft.com/download/en/details.aspx?id=11393

You can also turn on Exchange mailflow logging and use that and GFI logs / switchboard.

None of this will help if the delay is outside your organisation though, but if it is hitting GFI and then getting delayed there, you want to know about it.

A quick fix might be to whitelist the address which should take GFI out of the equation.

I would also use this site to check your mail configuration has no problems (reverse DNS missing etc) as this may make AOL view your mail server as suspicious which could cause delay errors, although you would normally expect to see delays the other way if this was the case.

Still better to have everything configured properly!

http://www.mxtoolbox.com/diagnostic.aspx

If you learn anything more about the problem, then let us know as this might shed some light on the situation.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

htabbachAuthor Commented:
Thanks for the reply, my wife has an AOL account and she can email me fine so I don't think we have an issue with AOL. Reverse DNS is setup correctly.
0
scriven_jCommented:
Did you try the whitelist suggestion?  Your wife is probably already whitelisted (manually or automatically) as I presume you send her messages quite frequently.
0
htabbachAuthor Commented:
I completely disabled our spam filter system and he still had problems over the weekend sending us email, some went through, some did not with the same error message.
0
htabbachAuthor Commented:
By the way, my wife never emails my work, this was the first or maybe second time she emails e from her AOL account to test.
0
scriven_jCommented:
Do you have a firewall?  Cisco Pix configuration can cause these symptoms:-

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26177300.html
0
scriven_jCommented:
(link also referrs to Sonicwall firewall)
0
htabbachAuthor Commented:
Thank you for the link, I cannot find the SMTP fixup setting in my SonicWall
0
scriven_jCommented:
I think it is called SMTP Inspection.  Give me the model number and I'll try and find more detail.
0
htabbachAuthor Commented:
Thank you, the model is: NSA 2400
0
scriven_jCommented:
As outlined in this document:-

http://www.sonicwall.com/downloads/SonicWALL_NSA_2400_Getting_Started_Guide.pdf

From page 45:-

Go to Security Services, Gateway Anti-Virus.

In Enable Inbound Inspection, remove SMTP

From page 48:-

Go to Security Services, Anti-Spyware.

In Enable Inbound Inspection, remove SMTP

Save configuration.  Test.

** WARNING - DO NOT DO THIS IF YOU HAVE NO OTHER VIRUS DETECTION SOLUTION - THIS IS ONLY TO FIX THE CURRENT PROBLEM AS OUTLINED ABOVE AND I DO NOT RECOMMEND YOU DOING THIS IF IT IS THE ONLY LAYER OF PROTECTION FOR INBOUND EMAIL. ""

I suspect that this is probably in addition to your "normal" protection though and in that case, it's fine to turn it off (at the very least to test if that stops the above problem).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
htabbachAuthor Commented:
This may not be the cause for this issue, Gateway AV and Anti-Spam are not licensed on my firewall.
0
scriven_jCommented:
Are they definitely turned off though?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.