Solved

FTP Logon Issues IIS 7 Win2k8

Posted on 2011-09-15
3
1,749 Views
Last Modified: 2012-05-12
FTP has been working fine. I reset the password today and now I cannot get back in. I deleted the account and re-created it. We are using a local account to access a local ftp directory. The username and password are correct. this user account has full access to C:FTP - and has Allow RW FTP Authorization Rules.  In IIS when I go to Test Connection it fails for this user:
Authentication fails, Authorization Fails User Credential are invalid (C:\FTP)

530-User cannot log in, home directory inaccessible.
 Win32 error:   Logon failure: unknown user name or bad password.
 Error details: Configuration error: Can not log on locally to C:\FTP as user ftp_user with virtual directory password
 Filename: \\?\C:\Windows\system32\inetsrv\config\applicationHost.config
 Line: 233
530 End
Login failed.

Please Help
0
Comment
Question by:sparkis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
3 Comments
 

Author Comment

by:sparkis
ID: 36544455
I followed these isntructions below but After I restart IIS it does not recreate the Password attribute. Can anyone tell me what exactly I should remove from this:
password=”[enc:IISWASOnlyAesProvider:JKutj5iWEWPgbesk9VAKFfaMfml9ETPNFzMUEhlfYr1A5chajmkX8r2f0oY0O/hL:enc]

I removed everything including password=


Solved: IIS ERROR or Website Error “cannot log on locally as user with virtual directory passsword”
Go the the following directory:
C:Windowssystem32inetsrvconfig
edit “applicationHost” file
NOTE: DO MAKE A BACKUP OF THIS FILE BEFORE EDITING
The website which is not running, you will see the IIS details and Application Pool settings in this file.
REMOVE the PASSWORD ATTRIBUTE FROM THE FILE OF THE WEBSITE THAT IS NOT OPENING OR GIVING ERROR LIKE BELOW
In my case the password attribute was something like below
password=”[enc:IISWASOnlyAesProvider:JKutj5iWEWPgbesk9VAKFfaMfml9ETPNFzMUEhlfYr1A5chajmkX8r2f0oY0O/hL:enc]
there will be possible two places where you need to remove this password field, you can copy paste the path from the error page , press CTRL+F to locate the path mention in the file and remove the password attribute from it. Close the file.
Reset IIS and you will see the new password will be auto generated, the field you removed will be auto created in the file and website will start functioning properly
0
 

Accepted Solution

by:
sparkis earned 0 total points
ID: 36544931
fixed the problem

IF you change the password make sure you make the change in IIS under basic settings - where you enter username and password.
0
 

Author Closing Comment

by:sparkis
ID: 36544934
fixed it
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question