enabling nfs rpc.mountd rpc.quotad on RHES Linux & permit them to be mounted on one NIC port


I have an RHES 5.x box but seems like it may have been hardened because
"service nfslockd start" or "service nfs start" just hang there.

I know & have set up /etc/exports (to permit which server to mount it).
Now I need the steps to bring up nfs daemon on this RHES 5.x box so
that other servers could mount it.

Also, let me know how I can ensure the NFS service is listening to a
specific LAN / NIC port only (ie can only be mounted via this NIC port)
sunhuxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nociSoftware EngineerCommented:
For the specific port , just allow the rpc protocol (SUNRPC, port 111 tcp & udp)  on the specified interface.

Did you also enable the portmapper? Any message in /var/log/* regarding nfslockd & rpc.bind?
0
Daniel McAllisterPresident, IT4SOHO, LLCCommented:
Hmmm... you've decided to to implement NFS at an odd time... specifically, when we're in the middle of upgrading from NFSv3 & the newer NFSv4.
If you want to read about it (high level, not too techie] try here HERE

Believe it or not, but I have found that, in general, the CentOS documentation and howto collections are superior to RedHat's -- even though CentOS is basically exploiting the GPL and re-releasing RHEL with different branding. (At least in the open-source market vendors tell the truth - usually - when the beg, borrow, or steal from someone else!)

So... here's another link to help you get your NFS running HERE

In closing, at first glance, I'd say that it appears you're trying to start NFSv3 and that you haven't started the portmapper service, so when the NFS daemons try to register, there is no answering portmapper service. The NFSv3 reliance on the portmapper is both a strength and a weakness... regardless, it is what it is and you have to run the portmapper (it listens on the port 111 that noci referred to above).

Good Luck!

Dan
IT4SOHO

PS: I'll say just this on the suitability of NFS:
 - If you're only using it on the LAN, use NFSv3 -- it's less secure and less optimal in performance, but FAR easier to get setup and running and over LAN circuits, should meet all but the most strenuous criteria.
 - If you're using NFS over the Internet, definitely go for the NFSv4 -- it's far more stable and secure. The tradeoff is that the added security makes implementation and administration harder.

0
ind_selvaCommented:
To make sure the proper nfs RPC-based services enabled for portmap issue this command

rpcinfo -p
showmount -e localhost - it shows nfs shares. on local system
showmount -e remotepc - it shows nfs share from the remotepc
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

sunhuxAuthor Commented:

# rpcinfo -p
rpcinfo: can't contact portmapper: RPC: Remote system error - Connection refused

#/etc/init.d/portmap start
Starting portmap:                                          [  OK  ]
# rpcinfo -p
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper


# service nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
Starting RPC idmapd:                                       [  OK  ]


I've also set the required remote nfs clients that need to be
able to mount in /etc/exports

So is that all I have to do & my NFS server is ready to serve?
0
sunhuxAuthor Commented:

Think I'm still missing something as "exportfs" returned nothing :

[root@localhost ~]# exportfs
[root@localhost ~]#
[root@localhost ~]# cat /etc/exports
/exports/nfs_export1    192.168.0.254(rw,insecure,no_root_squash,async)
/VolGroup00/test_nfs    192.168.0.10(rw,insecure,no_root_squash,async)
/VolGroup00/Nfs_lv2     192.168.0.10(rw,insecure,no_root_squash,async)
/VolGroup00/local-storage1      192.168.0.254(rw,insecure,no_root_squash,async)
[root@localhost ~]# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      29741864   4734832  23471852  17% /
/dev/cciss/c0d0p1       101086     12024     83843  13% /boot
tmpfs                  2043604         0   2043604   0% /dev/shm
/dev/mapper/VolGroup00-test_nfs
                      10095152   1824980   7757356  20% /VolGroup00/test_nfs
/dev/mapper/VolGroup00-Nfs_lv2
                      10095152   1051376   8530960  11% /VolGroup00/Nfs_lv2
/dev/mapper/VolGroup00-local--storage1
                      10095152    153760   9428576   2% /VolGroup00/local-storage1
0
sunhuxAuthor Commented:
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux OS Dev

From novice to tech pro — start learning today.