Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 526
  • Last Modified:

office 2007 suddenly says "word/excel/outlook/etc has not been installed for the current user. Please run setup to install the application"

see title.

uninstalled the whole suite, and re-installed, and still the same.

also downloaded the iso from my technet, same error.

please help :)

using windows xp sp3.
0
darkbluegr
Asked:
darkbluegr
1 Solution
 
AdrienneSperberTech Support CoordinatorCommented:
1) Create a Windows Account with full control admin rights, then log in to th
2) When under the newly created account, open every Office product you have, then close one at a time (Excel, Word, PP, etc...)
3) After opening every Office App, go into the registry editor (Start | Run, then type in Regedit)
4) Go to HKEY_CURRENT_USER | Software | Microsoft | Office, and highlight Office
5) Then right click on Office, and go to Export, save the .reg file to somewhere you will be able to find it (Root of C:\ for me)
6) Log off your temp Windows account, and log back in under your normal Windows account that was giving you the error.
7) Open regedit again, and then go to File | Import and pick the file that was exported.
 After it says that it was successfully imported, go ahead and try the app that was giving you problems.

Now it should work, just like it did for me. Also, remember you delete the temp account that you created!!
0
 
flubbsterCommented:
This is typically caused by an update to the office suite. Removing the software does not remove everything. Try deleting the mso.dll file in the following folder:

C:\Program Files\Common Files\Microsoft Shared\OFFICE12

After removal, perform a repair on the software using the add/remove programs utility.

You can also try this (from Microsoft about this issue)

Log on to the computer by using an Administrator user account.
Start Microsoft Windows Explorer.
On the Tools menu, click Folder Options.
Click the View tab.
Under Hidden files and folders, click Show hidden files and folders.
Click to clear the Hide extensions for known file types check box, and then click OK.
Open the following folder:
C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\
Right-click Opa11.dat, and then click Properties. Click the Security tab.
Click Advanced.
Click the Permissions tab.
Click to select Everyone in the Permission entries list, and then click Edit.
Click to select the Full Control check box.
Click OK three times.
If these steps do not resolve this issue, delete the Opa11.dat file from the following folder, and then restart an Office 2007 program.
C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now