[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 628
  • Last Modified:

Delayed Email Delivery Exchange 2010

We are running one MS Exchange 2010 on Server 2008 R2, virtualized through hyper-v, no SP on either.  

We seem to have remnants of the old 2003 exchange hanging in there somewhere.  We are experiencing our second round of fighting an issue where emails are delayed sometimes over 20 minutes.  You will not receive anything, then after a random amount of time, ten emails will drop into your inbox.  I had one email that I never received, but an hour later I got a reply to that email, than an hour after that I received the original email.  There are no events or helpful clues to go by.
0
LHFoods
Asked:
LHFoods
  • 5
  • 3
1 Solution
 
Sigurdur HaraldssonSystem AdministratorCommented:
Have you tracked the messages? I'd also check if there are any routing group connectors lingering in the Exchange organization.
0
 
LHFoodsAuthor Commented:
A little more detail.  It seems only to be the MAPI clients.  OWA and mobile devices get email in real time.
0
 
Sigurdur HaraldssonSystem AdministratorCommented:
What happens when you've got Outlook in online mode instead of cached mode?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Sigurdur HaraldssonSystem AdministratorCommented:
And I assume the Outlook clients are 2010?
0
 
LHFoodsAuthor Commented:
Yes.  Turning cached mode off in Outlook seems to help, but still not resolved.  We also have two exchange 2003 servers running (not being used, but services on) that I stopped all exchange services on.  So far it has not helped.  MS support is not able to track it down just yet.
0
 
LHFoodsAuthor Commented:
Microsoft is pretty sure it is a problem with the client (Outlook).  I turned cached mode off on another user profile and that literally fixed his email.  Apparently there is an issue with the ost files?  I am not sure it is a good idea to turn off cached mode on all of our computers, especially the laptops.
0
 
LHFoodsAuthor Commented:
Well the long and short is that the issue is fixed.  After a call to MS the throttling limits were temporarily adjusted until we installed SP1.  SP1 created a few more problems that have been resolved with Rollup 4.  I hate it when we have to break it to fix it ya know. lol

Thanks for your help and sorry that this took so long to post a resolution too.
0
 
LHFoodsAuthor Commented:
Issue resolved by MS and many wonderful patches.
0

Featured Post

[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now