Solved

Email Delay using Exhange 2003 server as an SMTP relay

Posted on 2011-09-15
7
940 Views
Last Modified: 2012-05-12
We currently have an Exchange 2003 SP2 server set up to relay mail from servers in our network to Postini for external mail delivery.  One of my programmers has set up a job to automatically send an email to a customer when they fill out a form on our website.  The email is being delivered, but it looks like there is anywhere from a 10 minute to 2 hour delay in delivering the email.  From the header, it looks like the delay is happening at the exchange server, but I'm not sure why this is happening.  Any ideas? See below for a copy of the header information from one of the emails:

Delivered-To: CUSTOMER@gmail.com
Received: by 10.231.12.71 with SMTP id w7cs25738ibw;
        Mon, 12 Sep 2011 15:38:11 -0700 (PDT)
Received: by 10.68.33.201 with SMTP id t9mr2369296pbi.148.1315867090941;
        Mon, 12 Sep 2011 15:38:10 -0700 (PDT)
Return-Path: <Administrator@COMPANY.com>
Received: from exprod5og106.obsmtp.com (exprod5og106.obsmtp.com [64.18.0.182])
        by mx.google.com with SMTP id a7si10649274wfg.113.2011.09.12.15.38.10;
        Mon, 12 Sep 2011 15:38:10 -0700 (PDT)
Received-SPF: neutral (google.com: 64.18.0.182 is neither permitted nor denied by best guess record for domain of Administrator@COMPANY.com) client-ip=64.18.0.182;
Authentication-Results: mx.google.com; spf=neutral (google.com: 64.18.0.182 is neither permitted nor denied by best guess record for domain of Administrator@COMPANY.com) smtp.mail=Administrator@COMPANY.com
Received: from RELAYEXCHANGESERVER ([IPADDRESS]) by exprod5ob106.postini.com ([64.18.4.12]) with SMTP
      ID DSNKTm6J0sgly73p8JEvFVcE8Cw3B7I8aBXV@postini.com; Mon, 12 Sep 2011 15:38:10 PDT
Received: from SENDINGSERVER ([10.146.20.45]) by RELAYEXCHANGESERVER with Microsoft SMTPSVC(6.0.3790.3959);
       Mon, 12 Sep 2011 15:28:09 -0700
Received: from mail pickup service by esd-services with Microsoft SMTPSVC;
       Mon, 12 Sep 2011 15:28:07 -0700
Reply-To: <custsvc@COMPANY.com>
From: "My Account System" <administrator@COMPANY.com>
To: <CUSTOMER@GMAIL.COM>
0
Comment
Question by:gobears1294
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
7 Comments
 

Author Comment

by:gobears1294
ID: 36545431
I've done a little more digging and found that the email message is definitely being delayed at the relay exchange server.  I tracked the message and found that the delay occurs when it's placed in "SMTP: Message Routed and Queued for Remote Delivery".  It eventually reaches the "SMTP: Started Outbound Transfer of Message" and the message is sent to postini with no further delays.
0
 
LVL 9

Expert Comment

by:Benjamin MOREAU
ID: 36545437
Maybe you have a problem with your SPF configuration, so, Google server consider your server as a spam server. Check this to configure SPF correctly : http://www.openspf.org/
0
 

Author Comment

by:gobears1294
ID: 36545459
I just checked our outbound queues and there is one of the messages located in the "Messages with Unreachable Destination" queue.  However, the recipient domain is @comcast.net and I verified that the recipient email address is valid by entering the address in an email address checker online.  I assume, this email will eventually be sent.  But I'm still confused as to why the email would get stuck in the Unreachable destination queue.
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:gobears1294
ID: 36545715
Now that I'm monitoring the queues, I see that a lot of out bound mail hits the "Outbound Mail Queue", then is sent to the "Messages with an Unreachable Destination" queue before eventually being successfully sent 15 minutes later.
0
 

Author Comment

by:gobears1294
ID: 36545743
Moreau37,

Thanks for the reply.  Here's the result of the test I sent to OpenSPF.  Unfortunately, I don't know where to go from here.
     


      Subject:      
      Sent:      9/15/2011 12:26 PM

The following recipient(s) cannot be reached:

      spf-test@openspf.org on 9/15/2011 12:26 PM
            You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            <exchangeserver.win.company#5.7.1 smtp;550 5.7.1 <spf-test@openspf.org>: Recipient address rejected: SPF Tests: Mail-From Result="none": Mail From="me@company.com" HELO name="exprod5og115.obsmtp.com" HELO Result="none" Remote IP="64.18.0.246">

0
 

Accepted Solution

by:
gobears1294 earned 0 total points
ID: 36546496
I found the solution.  It appears that there is an issue with exchange and postini.  After I changed the "number of messages per connection" to 1, mail flow was much better.  This is from a blog by Aaron Tiensivu (http://blog.tiensivu.com/aaron/archives/1134-Having-trouble-using-Postini-as-a-service-with-your-Exchange-server-I-have-a-workaround..html):

This issue has been talked about at length in the Exchange newsgroups here without any real resolution to the problem. Various things tried were setting the SuppressStateChanges registry key, which is a good idea anyway if you ever plan on going to Exchange 2007, and also shortening the Glitch Retry Interval value.

The problem happens when you have a batch of e-mails destined for various mail servers and you have one (or more) e-mail that triggers an error.

As an example, if you have 200 messages to deliver through Postini, and you have your SMTP virtual server set to deliver 200 messages per connection, if one e-mail gets rejected by any server, all 200 e-mails will get dumped into the Messages with an unreachable destination queue. More outgoing e-mail will start to pile up on top of the 200 e-mail messages, until the retry interval is reached or you find and delete the offending e-mail that punted all the e-mail into the unreachable destination bin.

The not exactly elegant, but usable workaround? Set the Limit number of messages per connection to: in your SMTP virtual server to 1. It isn't the most efficient method of transferring e-mail, but it will at least keep your e-mail flowing without using various registry hacks to short circuit Exchange's routing engine.


0
 

Author Closing Comment

by:gobears1294
ID: 36565527
I found this solution on my own online.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question