[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 672
  • Last Modified:

Listener issues

when i enter command lsnrctl status , i am seeing the instance is blocked, can anyone help me here., i am creating standby database, but in my auxiliary database,i am seeing my listener status is blocked. below is the output.
SQL> !
[oracle@sdbhost sdb1]$ lsnrctl status

LSNRCTL for Linux: Version 10.2.0.4.0 - Production on 15-SEP-2011 15:39:24

Copyright (c) 1991, 2007, Oracle.  All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for Linux: Version 11.2.0.1.0 - Production
Start Date                15-SEP-2011 15:36:59
Uptime                    0 days 0 hr. 2 min. 25 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Parameter File   /app/grid/product/11.2.0/grid_11202/network/admin/listener.ora
Listener Log File         /app/base/grid/diag/tnslsnr/houxpdbbkup01/listener/alert/log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC1521)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=houxpdbbkup01.ad.bgep.co.uk)(PORT=1521)))
Services Summary...
Service "+ASM" has 1 instance(s).
  Instance "+ASM", status READY, has 1 handler(s) for this service...
Service "sdb1" has 1 instance(s).
    Instance "sdb1", status BLOCKED, has 1 handler(s) for this service...
Service "sdb1_XPT" has 1 instance(s).
  Instance "sdb1", status BLOCKED, has 1 handler(s) for this service...
The command completed successfully

0
ajaybelde
Asked:
ajaybelde
  • 5
  • 5
1 Solution
 
slightwv (䄆 Netminder) Commented:
I believe this means the database cannot accept any more connections.

Connect 'as sysdba' and check the processes parameter then look at the number of sessions connected.

The online networking docs should be able to confirm the 'blocked' status meaning.
0
 
ajaybeldeAuthor Commented:
SQL> show parameter processes

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
aq_tm_processes                      integer     0
db_writer_processes                  integer     3
gcs_server_processes                 integer     0
job_queue_processes                  integer     10
log_archive_max_processes            integer     2
processes                            integer     150
SQL>


there is no database in this ..
 the database is in nomount stage. because i have to connect as auxiliary i have to issuse the command. when i am tried to the sstatus the listener is blocked for this instance.
0
 
ajaybeldeAuthor Commented:
SQL> select sid,serial# from v$session;

       SID    SERIAL#
---------- ----------
       170          1
       160          1
       169          1
       168          1
       167          1
       166          1
       165          1
       164          1
       163          1
       158          1
       159          1

       SID    SERIAL#
---------- ----------
       161          1
       148          1
       162          1
       150         21
       157          1
       155          1
       154         10
       153          9
       152         14

0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
slightwv (䄆 Netminder) Commented:
Going from memory but I believe in nomount you cannot connect through the listener.  This is why it shows blocked.
0
 
ajaybeldeAuthor Commented:
i am getting another error while i am connecting to rman

rman target sys/password@sourcetnsname auxiliary /

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of Duplicate Db command at 09/15/2011 16:53:32
RMAN-03015: error occurred in stored script Memory Script
RMAN-06026: some targets not found - aborting restore
RMAN-06024: no backup or copy of the control file found to restore


but the backup is in the directory.
0
 
slightwv (䄆 Netminder) Commented:
>>another error

Does this need to be a different question?
0
 
ajaybeldeAuthor Commented:
Same question, everything is interlinked with all, since my listener is blocked, i am unable to connect to rman i got this errors i am unable to figure out the problem i an continously getting issues
0
 
slightwv (䄆 Netminder) Commented:
You are unable to connect remotely.

Can you connect to rman locally (on the rman server itself)?
0
 
ajaybeldeAuthor Commented:
Yes, i am able to connect to locally in rman in both the servers but when i am issuing duplicate command i am getting the error which i earlied posted
0
 
Praveen Kumar ChandrashekatrDatabase Analysist Senior Commented:
This error is because you have to issue the

alter system archivelog current;

check this related isssue.

http://www.experts-exchange.com/Database/Oracle/Q_27311033.html?cid=1576
0
 
slightwv (䄆 Netminder) Commented:
>>check this related isssue.

That question doesn't appear to be related to this one.

>>duplicate command i am getting the error which i earlied posted

What steps are you following?  I've not done any duplication using RMAN but I'm thinking you might have missed a step somewhere.

Here are the Oracle docs that talk about this:

http://download.oracle.com/docs/cd/B19306_01/backup.102/b14191/rcmdupdb.htm#i1006579
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now