Solved

FreePBX/Trixbox Cannot keep a active trunk with 3com VCX

Posted on 2011-09-15
8
842 Views
Last Modified: 2012-05-12
I am in the process of replacing a Trixbox with a updated FreePBX system which trixbox is based on FreePBX interface so the setup is almost the same.  The configurations from the one has been manually transferred to the other system. We are running into a issue where the FreePBX <=> VCX keeps losing its connection.
This worked fine in the past when it was on the Trixbox we ran it no problems at all.
On the FreePBX we keep seeing the below errors.

FreePBX is at 192.168.0.34
VCX is at 192.168.100.190

We are positive without a double there is NO network disruption or anything between the VCX and FreePBX.

Does anyone have any ideas on the cause?

Here is the trunk config
allow=ulaw
canreinvite=no
context=from-pstn
disallow=all
host=192.168.100.190
insecure=very
nat=yes
port=5060
qualify=yes
type=peer


allow=ulaw
canreinvite=no
context=from-pstn
disallow=all
host=192.168.100.190
insecure=very
nat=yes
port=5060
type=user



[2011-09-15 15:30:30] NOTICE[3163]: chan_sip.c:24251 handle_request_register: Registration from '<sip:192.168.0.34>' failed for '192.168.100.190:5060' - No matching peer found
[2011-09-15 15:30:39] NOTICE[3163]: chan_sip.c:20169 handle_response_peerpoke: Peer 'VCX' is now Reachable. (83ms / 2000ms)
[2011-09-15 15:32:27] NOTICE[3163]: chan_sip.c:24251 handle_request_register: Registration from '<sip:192.168.0.34>' failed for '192.168.100.190:5060' - No matching peer found
[2011-09-15 15:34:27] NOTICE[3163]: chan_sip.c:24251 handle_request_register: Registration from '<sip:192.168.0.34>' failed for '192.168.100.190:5060' - No matching peer found
[2011-09-15 15:36:27] NOTICE[3163]: chan_sip.c:24251 handle_request_register: Registration from '<sip:192.168.0.34>' failed for '192.168.100.190:5060' - No matching peer found
[2011-09-15 15:38:27] NOTICE[3163]: chan_sip.c:24251 handle_request_register: Registration from '<sip:192.168.0.34>' failed for '192.168.100.190:5060' - No matching peer found

Open in new window

0
Comment
Question by:tsukraw
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
8 Comments
 

Author Comment

by:tsukraw
ID: 36546082
One thing i should add is VCX does not do any kind of authentication for PBX to PBX connections.  You just add the source IP as a trusted IP address and it will accept any incoming SIP connections.
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 36546383
I noticed you changed the type from user to peer..or visa versa.  Have you tried using type=friend?

Also, I see  nat=yes    are you sure that is correct?   How are the two networks connected?  vpn? public ip's? direct link?
0
 

Author Comment

by:tsukraw
ID: 36546398
vpn tunnel.  Should that be nat=no?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:tsukraw
ID: 36547095
I think you miss understood my posting
The top part was the outgoing trunk settings bottom was incoming.
.:OUTGOING:.
allow=ulaw
canreinvite=no
context=from-pstn
disallow=all
host=192.168.100.190
insecure=very
nat=yes
port=5060
qualify=yes
type=peer

.:INCOMING:.
allow=ulaw
canreinvite=no
context=from-pstn
disallow=all
host=192.168.100.190
insecure=very
nat=yes
port=5060
type=user
0
 

Assisted Solution

by:tsukraw
tsukraw earned 0 total points
ID: 36547194
Ok i know i am going to sound like a idiot here but figured out what the cause was....
FreePBX has a new feature that trixbox didnt have... "Intrusion Detection"  It would auto ban the VCX if it thought it was trying to intrude in...That is why it was working some times and other times not since it was a timed ban...
I discovered this when i was doing a PING from the FreePBX to the VCX.  I could do a ping just fine then it would randomly stop even though i could ping other devices just fine on the 192.168.100.x network.

When i initially did the testing of the network it must have been in its working period cause the ping worked.

0
 
LVL 25

Accepted Solution

by:
Ron Malmstead earned 500 total points
ID: 36549280
Got it.


To answer your question, If it's a vpn tunnel you don't need NAT, unless NAT is applied to the tunnel.  In most cases it isn't.
0
 

Author Closing Comment

by:tsukraw
ID: 36941237
Figured out the issue.
0
 

Author Comment

by:tsukraw
ID: 36918308
Please Close
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The point of this post is to give you a copy/paste installation solution to setting up Asterisk 1.6 on Ubuntu 9.04 (or similar) server. # Setup the system apt-get install subversion apt-get install make apt-get install linux-source kernel-p…
So you think no one can listen in on your VOIP conversations, eh? Well... if you haven't setup Secure Real Time Transport (SRTP), your voice communications can be hacked into by just about anyone! First, let's talk about the intended audience for…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question