Error when adding datastore in VMware ESXI 5

Posted on 2011-09-15
Last Modified: 2012-05-12
Hello Experts,

I just installed VMware's ESXi 5.0 on a new server of ours. I also made sure the Hardware and Raid controller was compatible before purchasing. I installed the Hypervisor on a flash drive and am planning on using the Raid Controller for the datastore.

Raid info:
PERC 6/i SAS internal RAID adapter, PCI-Express

The storage shows up under devices and everything looks fine.(See devices.jpg)
snapshot of Esxi resources
When I try to add it to a datastore I get this error:

"The operation failed because the specified directory path is incorrect."

Recent Task:
Create VMFS datastore
A specified
was not
9/15/2011 10:04:50 AM
9/15/2011 10:04:50 AM
9/15/2011 10:04:50 AM

I have several esxi host and this is the first time I have seen this problem and google isn't helping. Can someone help me figure this out?
Question by:mlsbraves
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
LVL 121
ID: 36546290
It's possibly because it already has a partition on it. (all the other versions do this if there is a partition on the disk!)

Remove the partition with GPartED Live CDROM.
Download Gparted Live CDROM (

or Scrub the disks, if you have that option on the RAID controller.

Author Comment

ID: 36546363
This is a remote server which I can access through the iDRAC6 Management card. I do believe I can mount a local cd and boot from it, I will have to check. Is there a reason a partition already exist on the new server? No OS was shipped with it so unless it is used for something else I don't understand. I just don't want to remove a partition before knowing it doesn't effect anything.
LVL 121
ID: 36546372
I have no idea, but if you look at the screenshot, it believes there is a Win 95 FAT32 2GB partition on the RAID array.

The only way of checking is using another disk manager.

Were the disks new?

It's certainly not an ESXi 5.0 partition.
When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

LVL 121
ID: 36546380
You could also check with fdisk at the console, but sometimes, it's difficult to "nuke" a partition whilst ESXi is memory resident.

Author Comment

ID: 36546388
Yes this is a brand new server from Dell.
LVL 121
ID: 36546393
Check with Gparted Live CDROM

Author Comment

ID: 36547092
gparted display
So there's two partitions.

DellUtility & 2gb fat32.

Expert Comment

ID: 36547187

so hanccoka's solution should work, just delete the two Dell partition. partition type 0xde is Dell recovery partition.
LVL 121

Accepted Solution

Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 36548539
Yes, okay, so you've got a Dell Management partition, Fat 16 and Fat32 OS partition.

Remove them both, and clear the disk.

Author Comment

ID: 36550658
Deleted both partitionsI deleted both partitions but I still am getting the same error:
 Still recieving same error
LVL 121
ID: 36550705
Escalate and Open an SR with VMware Support.

Assisted Solution

mlsbraves earned 0 total points
ID: 36550798
Don't have support right now. I was able to finally figure it out. I didn't think it would matter if I renamed the name of the device. But apparently it does. I right clicked the device and selected "Copy identifier to clipboard" and pasted this as the name. Tried it again and it worked.

 Result after renaming device

Author Closing Comment

ID: 36572273
Figured out that you can't rename the device name. Changed it back and everything worked. It was also helpful to know to remove all partitions before adding it to a datastore. Thanks.
LVL 121
ID: 36550871
It clearly didn't like your SAS name, which is the first error specified directory path is incorrect.

But with partitions on the device, it would not have created the VMFS datastore.

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will show you how to create an ISO CD-ROM/DVD-ROM image (*.iso), and MD5 checksum signature, for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5). It's a good idea to compare checksums, because many installations fail because of a corr…
In this step by step tutorial with screenshots, we will show you HOW TO: Enable SSH Remote Access on a VMware vSphere Hypervisor 6.5 (ESXi 6.5). This is important if you need to enable SSH remote access for additional troubleshooting of the ESXi hos…
Teach the user how to configure vSphere clusters to support the VMware FT feature Open vSphere Web Client: Verify vSphere HA is enabled: Verify netowrking for vMotion and FT Logging is in place or create it: Turn On FT for a virtual machine: Verify …
Teach the user how to use create log bundles for vCenter Server or ESXi hosts Open vSphere Web Client: Generate vCenter Server and ESXi host log bundle:  Open vCenter Server Appliance Web Management interface and generate log bundle: Open vCenter Se…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question