• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 727
  • Last Modified:

IPhone4 will not connect to SBS2011

I have just set up a new Microsoft Small Business server 2011.
I have registred a Thawte SSL123 certificate and I can confirm that this is working.
I have full access from WAN to OWA.

HOWEVER I can't get the IPhone4's to connect!

I use a kind of "standard" configuration which I have used for several customers.

On the IPhone4 I do the following:

- Go into settings / Email /add Exchange
- Enter e-mail address  user@domain.com
- DOMAIN: internal domainname
- USERNAME: user
- Password: pw


SERVER: remote.domain.com


Now it says "Can not verify account credentials"  (or something a like - translation from Danish)

OK - Save

When I try to go into mail it just says INCORRECT PASSWORD
(Im sure its the correct pw??)

Any clues?
  • 2
  • 2
1 Solution
Alan HardistyCo-OwnerCommented:
What sort of SSL Cert did you install and how many names are included in the certificates?

Did you include the following names:

mail.externaldomain.com (or whatever you chose to configure it as)

Have you also created an Autodiscover A Record in your External DNS records for your domain and pointed that A record to the IP Address of your SBS server?

Visit https://testexchangeconnectivity.com and run the Exchange Activesync Autodiscover test and report nack the results if you have done ALL of the above and it is still failing.
OhmitAuthor Commented:
Hi Alan

It is a thawte SSL123 certificate.

Well I normally just include REMOTE.DOMAIN.COM

I have never entered the other information when ordering a certificate?
Alan HardistyCo-OwnerCommented:
With Exchange2 007 and 2010 (which is included in SBS 2011), you need to order a SAN / UCC (Multi-Name) SSL certificate with the above names or some aspects of Exchange won't work.

Whenever I install SBS 2008 or SBS 2011, I order a 5-name SSL cert, import it and enable it, then everything works.

The Autodiscover A record is also required (or the creation of an SRV record in DNS instead).

If you do the above - Exchange / SBS will be 100% happy.
OhmitAuthor Commented:
hmm well I dont know what is happening here because suddently it seems to work!

Another funny thing is that it seems like the SBS is applying some secury settings to the IPhone.
Now the IPhone demands code to unlock which I can not remove!

The "Remove code" field is greyed out unless I remote the Echange account again??
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now