Solved

New Users not appearing in Global Address list

Posted on 2011-09-16
23
1,432 Views
Last Modified: 2012-08-14
Hi

New users that have been created in our Exchange 2010 environment are not appearing in the Global Address List.

However they are appearing in the "All Users" address list.  We are running Outlook 2007 and Outlook 2010 in cached exchange mode.

If we were to use Outlook Web Access and click on the Global address list then we can see the new users.  This would seem to point at the issue being with the "Offline Address Book" which is what I think Outlook clients working in cached mode get to see.

This is not a case of waiting for eplication as some of these users were created over a month ago.

We have 2 exchange servers in our Organization.  One based in the US and one here in the uk.  The users that are not appearing in the Global address list have all been created on the UK Exchange server and are on the UK Exchange server database.

Does anybody have any suggestions on how I can rectify this as people are begging to ask why they can not find new users in the Global Address list.

Regards

Kevan
0
Comment
Question by:cmiadmin
  • 12
  • 5
  • 5
  • +1
23 Comments
 
LVL 26

Expert Comment

by:e_aravind
Comment Utility
so looks like OAB files are not getting updated?

> Outlook online mode should also be showing the newly created user-accounts.

> what is the status of the Outlook "Cached Exchange mode" after couple of days?
(1 day for the OAB generation + 1 day (max) for the OAB distribution)
0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
Outlook Online mode shows all addresses correctly.

Outlook in Cached mode does not show newly created users.  This has been going on since the end of July.  So plenty of time for OAB Generation and distribution.
0
 
LVL 16

Expert Comment

by:Auric1983
Comment Utility
cmiadmin

Can you open up Exchange Management Console (EMC) and expand Organization Config > Mailbox
select the "Offline Address Book"

Select your default offline address book.  Right click on it and select properties

1. ON the general tab, ensure that the update schedule is set to run daily
2.  On the address list tab ensure that "Include the default GAL" is ticked
3.  On the distribution tab make sure that "enable web-based distribution" is selected.

Click OK to close the window.

---

On your outlook client hold CTRL and right click on the outlook icon in the task bar.  Select "Test email autoconfig" and clear the "use guessmart" and "use guessmart authentication"  checkboxes and hit OK.

0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
Hi

There is no tick in the box for "Enable Web-based distribution".

There is a tick in the box for Enable Public Folder distribution.  (We do still have a few Outlook 2003 clients)
 There is also a tick in the box for "Client Support" "Outlook 2003 SP2 or latter"


If I put a tick in the box for Enable Web-based distribution I am asked for the Virtual directory.
I am eventualy presented with a choice of 2 locations.  One on our server and one on the Exchange server in the US.

The US one was the first one installed in the organization (If that makes a difference)  Which one should I chose?


0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
On the General TAB of the Offline Address List Properties, it says that the "Generation Server" is the server based in the US.

Default Offline Address Book: True.
0
 
LVL 16

Expert Comment

by:Auric1983
Comment Utility
It should be enabled on the same server that is doing the GAL processing, but you really can deploy it from any of the servers.

Are the clients having the problem running Outlook 2007 or 2010?
0
 
LVL 16

Expert Comment

by:Auric1983
Comment Utility
The other thing you will want to double check is that your autodiscover configuration is working correctly.  Autodiscover is extremely important in Exchange 2007/2010 as this is where the clients get all of their config info, including the web url of the offline address book.

0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
OK
Yesterday I ticked the box for "Enable Web Based Distribution" and chose both the virtual directory on the server in the US and the Virtual Server in the UK.  I changed the Update schedule to run daily at 1am.

This morning the new users have still not appeared in the Off Line Address book.

When I test that Auto Discovery is working OK I notice that the OAB URL is set to "Public Folder"

Shouldn't this say something else now that I have Enabled Web Based Distribution.
0
 
LVL 16

Expert Comment

by:Auric1983
Comment Utility
You could try the 'update-offlineaddressbook" cmdlet on the exchange server see > http://technet.microsoft.com/en-us/library/aa995979.aspx

Can you manually download the OAB one one of the affected clients?? under Send/Receive / download OAB
0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
Hi

I can not update the OAB from the Outlook client.  I get an error 0x80190194. I get this on a couple of clients that I have tried.

 
0
 
LVL 16

Expert Comment

by:Auric1983
Comment Utility
Thanks CMI
that error message might actually help solve why its not updating automatically

Check this out http://blogs.msdn.com/b/dgoldman/archive/2006/11/27/error-0x80190194-when-using-an-outlook-2007-client-to-download-a-web-distribution-enabled-oab.aspx

0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
Could this also be a reason for the OAB not updating?
I ran the update-offlineaddressbook cmdlet and got the error below.

NSFCMI-4 is a DC (Not an Exchange server) on our network.  the server generating the OAB is the exchange server in the US.
............................................................................................................................

[PS] C:\Windows\system32>update-offlineaddressbook -identity "Default Offline Address Book"
The operation couldn't be performed because object 'Default Offline Address Book' couldn't be found on 'NSFCMI-4.oxford
.nsf.org'.
    + CategoryInfo          : NotSpecified: (0:Int32) [Update-OfflineAddressBook], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : 2ABBF331,Microsoft.Exchange.Management.SystemConfigurationTasks.UpdateOfflineAddressBook


......................................................................
0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
I am reading through the link you posted earlier.
0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
Hi according to the Event viewer on the exchange server in uk, My Server.  synchroniation occured OK.  
.................................................................................
Process MSExchangeFDS.exe (PID=748). The offline address book synchronization cycle is complete.  2 offline address book(s) were successfully synchronized.
.....................................................................................

However there are 2 folders in the \ClientAccess\OAB folder. There are 2 Offline Address Books defined in our organization.  One has lots of files in and the other is empty?

0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
Sorry forget my last post about

PS] C:\Windows\system32>update-offlineaddressbook -identity "Default Offline Address Book"
The operation couldn't be performed because object 'Default Offline Address Book' couldn't be found on 'NSFCMI-4.oxford
.nsf.org'.
    + CategoryInfo          : NotSpecified: (0:Int32) [Update-OfflineAddressBook], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : 2ABBF331,Microsoft.Exchange.Management.SystemConfigurationTasks.UpdateOfflineAddressBook

I had a typo in the name of my offline address book.


0
 
LVL 20

Expert Comment

by:Hendrik Wiese
Comment Utility
Try the following: Update-GlobalAddressList -Identity "Global Address List" -DomainController "YourDomainControllerName"

If that does not work, then try this:
1. Go to the EMC > Organization Configuration > Mailbox Node > Offline Address book tab and click update on the Default OAB,
Then  check the “Date modified” attribute of LZX files under …\Exchange Server\ExchangeOAB
2. Restart “ Microsoft Exchange File Distribution” service,
Then check the “Date modified” attribute of LZX files under …\Exchange Server\ClientAccess\OAB
If both “Date modified” attribute is the latest time, it means you have update OAB successfully.
3. Force Outlook updating OAB.
Restart Outlook or press “Send/Receive”àClick “send/Receive Groups”àClick “Download Address Book”
0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
Hi

First there are 2 Exchange 2010 servers in our Organization.  1 in America and 1 in UK.
The American server was the first in the Organization.
I am working on the UK server.

In the EMC Under Organization > Mailbox > Offline Address Book, there are 2 address books listed.
Default Offline Address Book and NSF-CMi Offline Address Book.
The Generation Server for both Address lists is the Exchange server in America.

On my server under \Exchange Server\V14\ExchangeOAB there is one folder. the newest .lzx files are dated 24.07.11  This is about the time that the Offline Address List stopped updating.

Under \Exchange Server\V14\Client Access\OAB there are 2 folders. The Folder with a coresponding name to the Folder under ExchangeOAB is empty.  The other folder has the latest .lzx files as today.

When I Test Outlook Connectivity on My Outlook. I can see that the URL for my OAB is pointed at the Directory which is Empty under \ClientAccess\OAB and out of date uner \ExchangeOAB.

I think that this is where my problem lies.  Do you have any more suggestions please to fix this issue?










0
 
LVL 20

Expert Comment

by:Hendrik Wiese
Comment Utility
Did you Restart the “ Microsoft Exchange File Distribution” service?
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
Comment Utility
You can also try to copy the latest .lzx files to the outdated location on your server. And then restart the “ Microsoft Exchange File Distribution” service.
0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
Hi

I could do that but that will not help me going forward.  New users will appear in the Global Address list but not in the Offline Address book as my download point will not be upto date.

I did restrat the “ Microsoft Exchange File Distribution” service.
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
Comment Utility
I think do the manual copy, and restart the server when you have a gap. Then monitor is and let me know if the file gets updated or not?
0
 
LVL 1

Author Comment

by:cmiadmin
Comment Utility
OK

If I copy the .lzx files do I copy them into the \exchangeOAB\OABFolderName or into the \ClientAccess\OAB\OABFolderName  or to both?
0
 
LVL 20

Accepted Solution

by:
Hendrik Wiese earned 500 total points
Comment Utility
You can copy them to both
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now