Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1424
  • Last Modified:

coldfusion 8/9 - apache 2.2 issue

Hello experts.
Since yesterday i was workin and testing at home using cf8 and apache 2.2.
I decided to test cf 9 on the same machine after formating and reinstalling windows xp pro sp3.
I downloaded this newest apache file: httpd-2.2.21-win32-x86-ssl

trying to install cf 9 and selecting enterprise multiserver configuration or server configuration
settings:
add webserver
cofiguration directory :  C:\Apache2\conf
directory and file name of server binary: C:\Apache2\bin\httpd.exe

i get the error :
adobe coldfusion9 does not support this version of apache. the earliest supported apache versions
are 1.3.12 or later for apache 1.x and 2.0.43 or later for apache 2.x

I tried the same installation with cf 8 but the result was the same.

I did test this with an older apache version 2.2.19 wich was working with cf8 (before format) but it does not work  with cf8 or cf9 installation .

any help?
0
Panos
Asked:
Panos
  • 2
1 Solution
 
PanosAuthor Commented:
Here is my expirience and i how i solved this problem:

1.coldfusion installation fails with apache-ssl version.
Because that install first a none ssl version like :
httpd-2.2.21-win32-x86-no_ssl
(use installation folderC:\Apache2)
2.install coldfusion cf8/9
3.install coldfusion update 8.01/9.01

4.download httpd-2.2.21-win32-x86-ssl
5.stop coldfusion - apache services
6.Rename the first "apache2" folder to "Apache2_"
7.Create a new Apache2 folder and extract there httpd-2.2.21-win32-x86-ssl
8.Copy htdocs folder From "Apache2_" to Apache2 folder (replace existing one)
9.Add following lines to the bottom of your new httpd file in conf folder:
# JRun Settings
LoadModule jrun_module "C:/your_coldfusion_root_folder/runtime/lib/wsconfig/1/mod_jrun22.so"
<IfModule mod_jrun22.c>
    JRunConfig Verbose false
    JRunConfig Apialloc false
    JRunConfig Ignoresuffixmap false
    JRunConfig Serverstore "C:/your_coldfusion_root_folder/runtime/lib/wsconfig/1/jrunserver.store"
    JRunConfig Bootstrap 127.0.0.1:51800
    #JRunConfig Errorurl url <optionally redirect to this URL on errors>
    #JRunConfig ProxyRetryInterval 600 <number of seconds to wait before trying to reconnect to unreachable clustered server>
    #JRunConfig ConnectTimeout 15 <number of seconds to wait on a socket connect to a jrun server>
    #JRunConfig RecvTimeout 300 <number of seconds to wait on a socket receive to a jrun server>
    #JRunConfig SendTimeout 15 <number of seconds to wait on a socket send to a jrun server>
    AddHandler jrun-handler .jsp .jws .cfm .cfml .cfc .cfr .cfswf
</IfModule>
<Files ~ ".hbmxml$">
Order allow,deny
Deny from all
</Files>

11.Make the other changes for using ssl in httpd file (you can find this in net)

That's all. I hope someone will find this usefull.
0
 
PanosAuthor Commented:
I post my solution and hope that will help someone else
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now