Excel file saving

I have two computers, both running W7 and office 2010, on one computer, when I save an excel file that I received say via email, it automatically adds "copy of" to precede the file name by default. like this: "Copy of my spread sheet.xlxs". On the other computer, excel does not add "copy of" but does add underlines between all the words in the file name and a number at the end in paranthesis like this: "my_spread_sheet_(2).xlsx"

I cannot figure out for the life of me where I can change how Excel (or Word) handles default naming of files I am "saving". A few google searches turned up book.xlt in the XLstart folder as the default template for excel but if that is the right place, I still can't find any instructions to change these settings, not to mention that file does not exist on my computer....
swjtx99Asked:
Who is Participating?
 
Arno KosterCommented:
As far as I know, there are no excel settings for this.
The only way I could think of is when you have macro code (inside of the opened file or as an add-in) running which handles the save as event. This seems a rather long shot however, because for the computers to rename the files in different formats also different macro code should be present.

If this is seena s a big problem, you could concoct an excel add-in containing code to run instead of the regular save as option, stripping the underscores and copy of, and opening the regular save as dialog box with the updated filename

eg.
'-- get original filename
filename = ActiveWorkbook.Name
'-- strip underscores
filename = replace(filename, "_", " ")
'-- strip copy of
if lcase(left(filename,7)) = "copy of" then filename = mid(filename,7)
'-- open save as dialogbox
activeworkbook.SaveAs Application.GetSaveAsFilename(filename)

Open in new window



0
 
Arno KosterCommented:
When you download files from the internet, they will be saved in a 'downloads' folder. Some browsers such as google chrome automatically add (2) when the same file s downloaded again, and (3) / (4) etc for consequtive downloads.

I have not seen the adding of "copy of" before but that should be prevented by using "save as" functionality in excel.
0
 
jan24Commented:
Akoster is right - this is more likely to be to do with where the file has come from than to do with Excel itself.  Can you give a bit more detail about where the file came from in each of your two computers?
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
swjtx99Author Commented:
These are all mostly my own files or files from my company's network. I don't recall a specific file source as it seems to happen with all files but as an example, one of our software applications on a server sends me a report several times a day into my email. If I retrieve it from my primary comuter (outlook, double click to open in Excel 2010 do a file "save as") and save it, I get the "copy of" added, even though there's not already a file with that name in the directory I am saving it to. If a use the other computer (Webmail/outlook, double click to open in Excel 2010, file "save as") I get al lthe underlines between words of the filename and a number added to the end.

The name of the file as an attachment to the email is named something like "08-16-11 backlog report.xls" so whether I open it from Webmail or directly from outlook, the filename starts out the same. It's just when I open it in excel and do a save as that all this funny stuff starts to happen.
0
 
swjtx99Author Commented:
I guess there are no settings for this?
0
 
swjtx99Author Commented:
It's not just with Excel but I was hoping it might be an "MS Office" or W7 setting.

After a lot of google searches myself, I thought I'd give it one last shot here. Looks like it really does have everything to do with the origination (source) of the file. I just don't remember having these issues in WXP....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.