Solved

Change Local IP Addresses on a Workgroup Network

Posted on 2011-09-16
9
545 Views
Last Modified: 2012-05-12
Changing to new ADSL Provider

I have a new Xyzel router from the new ISP. I have connected it to the existing 16-port Netgear swuicth and connected 3 existing DHCP Clients (All part of the Same Windows Workgroup), an existing  LAN Storage device , which works but we no longer have access to administer it, (it is accessed by name e.g \\TheLanDevice\Myfolder  and a Sharp MFP which is leased as possibly has a static IP.

The router is pre-configured with local IP 192.168.1.1
The Network seems to use 192.168.2

I have changed the router IP to 192.168.2.1 and managed to change Client IPs, but cannot change the Printer or LAN device IP.

I have tyested using static IPs on te clients in the 2.x range and can access the Printer and LAN device. We seem to go between having access to Internet or the Printer/LAN Storage. When the Internet works with router set to 192.168.2.1  its very unreliable , the DSL and Internet lights on the router are constantly on/off etc. When its back on 1.1 its seems more stable but we cannot access the Printer/Storage unit.

Please advise

1)  how to dtermine the local IP of the Printer and LAN device from a Client PC

2)  the steps to take to properly configure all 6 devices onto a 192.168.1.x range with no conflicts

3) any cabling issues to check

0
Comment
Question by:ASPDaddy
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 2

Expert Comment

by:Mike
ID: 36549068
The Sharp MFP should have a display screen where you can cycle through settings. You should be able to change it's IP there.

You say your router/Modem from ISP was preconfigured to 192.168.1.1 then you reconfigured it to the same?

All IPs need to match based on the subnet mask. If the subnet mask is 255.255.255.0 All IPs must match the 3rd octet ie 192.168.1.X . So make sure DHCP is handing out the same as whatever you set the router to. If your devices were configured to 192.168.2.x 255.255.255.0 you could try setting your router's IP and DHCP settings to match. Make sure you match the default gateway in DHCP or on devices to match your routers IP.

Good Luck

0
 
LVL 6

Accepted Solution

by:
netjgrnaut earned 167 total points
ID: 36549085
1. Configure a client on the 192.168.2.0/24 subnet.
2. Verify that you can access \\TheLANDevice\Folder as normal.
3. Open a cmd prompt.
4. > PING TheLANDevice
5. (You should get back an IP address in the Reply from...)

Not sure how you're going to *fix* the LAN storage device, if you no longer have access to administer it.  If you post the make/model of the device, I might be able to help with that.

If your LAN printer is leased, you should have tech support from them.  I don't know the Sharp in particular, but if you poke around at the menus you should be able to find a network setup menu tree that will both display and reconfigure the IP info.

This video may help with that, depending on what model of Sharp you have...

http://www.lesolsoncompany.com/InstantKB20/KnowledgebaseArticle50216.aspx
0
 
LVL 12

Assisted Solution

by:kadafitcd
kadafitcd earned 166 total points
ID: 36549125
If it's unreliable when set to 2.X then it probably means that either the Printer or the NAS(Network Attached Storage) is causing your problems. I would disconnect the network cables from the 2 devices and test the Router on the 2.X with the clients.  If it works properly and is stable then plug in the printer first and see how stable the network is.  If it is unstable unplug it.  If it is stable plug in your NAS.  If it's unstable then it is your NAS device causing the problems.  If it is stable and the printer was unstable then it was your printer causing the problems.

Good Luck HTH.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:ASPDaddy
ID: 36549149
msprague74:, no I said
I have changed the router IP to 192.168.2.1

I cannot see any settings at all on the Sharp for IP or Network etc, I have looked several times in detail, however there is an adminsitrator password option.

>So make sure DHCP is handing out the same as whatever you set the router to
How ?

>If your devices were configured to 192.168.2.x 255.255.255.0 you could try setting  your router's IP and DHCP settings to match

Yes, they were. I have changed the router IP using its CPanel under LAN->Default Gateway Address. Are there other settings or steps to do this, the CPanel webpage hangs but does seem to change the address eventually. What commands should I run on the clients after this? What neees re-booting etc. Im just looking for  alist of steps to confirn the config is being applied properly before looking elsewhere
0
 
LVL 2

Assisted Solution

by:Mike
Mike earned 167 total points
ID: 36549241
IP change... Sorry, I shouldn't answer questions so early in the morning. :)

netigrnaut's suggestion to contact your sharp leaser is probably your best bet if you MFP is passworded and you want to make a change.

If you change your routers IP you will lose your connection to it and have to change your IP to match it's network.

You shouldn't change your routers gateway. Change what gateway DHCP is handing out. Find the tab for DHCP. Settings should look something lilke

Scope - 192.168.2.50 - 192.168.2.100 (or similar)
subnet mask - 255.255.255.0
default gateway - 192.168.2.1
DNS - (this is probably set to your ISPs DNS servers or your routers IP, leave these at default)

0
 

Author Closing Comment

by:ASPDaddy
ID: 36549278
Lots of helpful advice to move forward....Thx
0
 
LVL 12

Expert Comment

by:kadafitcd
ID: 36550481
>the CPanel webpage hangs but does seem to change the address eventually

Just wanted to mention.  If your CPanel hangs.  It may be due to the browser you're using.  I have had several routers not get along with firefox.  Mainly I do all my changes through Internet Explorer it just seems to work the best with Router Web Access Panels.
0
 

Author Comment

by:ASPDaddy
ID: 36554036
All sorted was actually the NAS device set to be a DHCP server that was the cause of conflicts, until we copy the files off it and hard-reset it we have simply:

Set the routers default gateway to 192.168.2.1 - the same range as the NAS and Printer
Turned off DHCP on the router
Released and renewed all teh client IPs

Everything works now!!
0
 
LVL 12

Expert Comment

by:kadafitcd
ID: 36554123
yeah sounds good.  To be honest you need to take care of that NAS ASAP.  If you don't have a password to it you need to reset the password and if you can't do that you need to replace it.  Being locked out of a source on your network is never a good thing.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
checking for updates 11 68
Open a port on Cisco Router 1941 23 40
windows explorer default details view 10 57
Network Vs Redistribute Connected Commands 3 9
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question