Microsoft Dynamics SL Project Integration Service wont stay started.

We are running the following.

Server1
Dynamics SL App server
SQL 2008 R2 DBs:
(Dynamics system and app)
(WSS for Business Portal)
(Project Server 2007 DBs)

Server2
Business Portal App
WSS 3.0 App

Server 3
Full SharePoint 2007 App sp2 + latest CU
Project 2007 Server App sp + latest CU
Microsoft Office Project 2007 Connector for Microsoft Dynamics SL
(Project Connector Integration service)
(Project Connector Extension)

Everything seems to be configured correctly but the Microsoft Dynamics SL Project Integration Service will not stay started.  It will start up but then it will close out about 10 seconds later with a .net event log error showing up (Attached)

I have also tried moving this service to the Server 2008 server and it is doing generally the same thing but since this server has .net 4 it just reports that the server unexpectedly quit.

I need help getting this service to start and stay started.

Capture.JPG
stuart100Asked:
Who is Participating?
 
stuart100Connect With a Mentor Author Commented:
This ended up being a script issue with the service.  It could not add the correct tables to the project tables due to a missing link in the SQL server back to itself.

John
0
 
TRUENEUTRALCommented:
Have you checked to make sure the ODBC driver for Dynamics is correct?  For some versions it is SQl Server and others it is SQL Server Native.
0
 
stuart100Author Commented:
Figured it out myself and it had nothing to do with ODBC which was the only other suggestion...thank you by the way for that suggestion.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.