• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 582
  • Last Modified:

IE8 on Win7Pro box, clicking link messes up tab

We have an app that we interface using IE8. I just set up a new user on a Win7Pro box and have IE8 set to open new tabs in same window.  This way we don't have a zillion instances of IE8 open, there is only one window with many tabs. That is all fine. The problem on this machine that we don't experience on XP Pro boxes is that when an IE8 tab has an email link somewhere on the page and we click, it does open a new Outlook email, but, the tab becomes a new, blank tab that has the email address in the address bar of the tab? We have to hit the "back" arrow to get back to the page the tab had been displaying. This does not happen on XP Pro IE8 tabs. On those machines we can press an email link that is displayed on an IE8 tab and the tab does not change. How do I fix this?
0
rodynetwork
Asked:
rodynetwork
  • 8
  • 5
  • 5
  • +2
2 Solutions
 
johnb6767Commented:
Does this affect other users as well, on this machine (create a new one to test if needed)?
Does this affect other Windows 7 machines?

Definitely not the default behavior.....

Maybe the URL:MailTo file association is messed up? On the Windows 7 Start Menu, type File Association, and select "Associate a file type or protocol with a specific program".

At the bottom, there is a MAILTO protocol, double click it and select MS Outlook (we are just resetting it basically)......

If needed, this is a much stronger interface for file associations.... Alternatively, reset the Default Email client via the Start Menu>Set Default Programs, or via the IE Options>Programs Tab....

FileTypesMan v1.61 - File Types Manager for Windows
http://www.nirsoft.net/utils/file_types_manager.html

We can investigate there if needed....
0
 
Randy DownsOWNERCommented:
Maybe this will help

http://stackoverflow.com/questions/1674527/mailto-causing-a-blank-page-in-ie8-when-used-with-dojo
 
 
The issue is the so called protected mode. Funnily if you have a page with a mailto link which has protected mode disabled and you have a mailto link and protected mode enabled for the internet, you run into this issue. IE tries to start the protected mode, and performs a page refresh by doing so against about: blank before starting the mail client. After that it tries to redirect to your original page and more often fails than is able to restore the page. In default settings you also get a security warning in between which you can disable with a checkbox. It all nails down to the problem to get the mailto link into the protected mode or to either disable the protected mode entire or to push your mailto page into the protected mode. The nastier issue even is that you cannot wildcard entire mailto links and if you add a generic domain wildcard ala *.example.com the mailto link mailto:myaddy@example.com still is not being recognized as part of the trusted domain. So I am not sure which strategy is the best to fix this, the best probably would be that Microsoft fixes their domain wildcarding system in the internet settings which still is the same as in IE.
0
 
ded9Commented:
Go to

Default Programs\Set Associations

under protocol ...mailto...make sure its associated with your email client.



Ded9
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ded9Commented:
Ignore my post it seems johnb6767: has covered it..did not see his comments.


Ded9
0
 
rodynetworkAuthor Commented:
@john6767 tried the first two suggestions, no change.  Visited the link you posted but not sure what to do with it?

@number1 that link describes what is happening, exactly, but how to correct it?
0
 
Randy DownsOWNERCommented:
You could try turning off protected mode to see if that helps. It's under Tools, security.

It's better to have protected mode on so you may want to try exempting the email address in your mailto.

http://answers.yahoo.com/question/index?qid=20080729063158AAqteYu

0
 
Randy DownsOWNERCommented:
You can try adding the email address to the trusted sites also in Tools, Security.
0
 
rodynetworkAuthor Commented:
Weird. On the machine I am on, I went to tools, security and unticked the Enable protected mode and that seems to have fixed it. It is not working on the other Win7 box.  I followed the same steps and then had her close IE and reopen. Still does it.
0
 
rodynetworkAuthor Commented:
as for adding the email address to trusted sites, that isn't practical.  We have hundreds of various email addresses that show up. It is driven by the vendor page we are accessing in IE8.  Thousands of vendors.  Anyway, there has got to be something else to look at. Not sure why the fix worked on this box but not on the other. Both are Win7Pro.
0
 
Randy DownsOWNERCommented:
Make sure you close all instance of IE. Also adding the address to trusted would be a better solution.

Maybe try clearing the cache or even rebooting the stubborn machine.
0
 
Randy DownsOWNERCommented:
OK, I see your point on the email addresses. The wild card didn't work according to that article but maybe Microsoft has fixed it by now. It would be worth a try to add *.domain.com Even that could be difficult if you deal with lots of sites.
0
 
rodynetworkAuthor Commented:
Any more suggestions?  I found that when I unticked "Enable protected mode" it fixed one machine but the other two machines still have the problem.  Unticking didn't fix it on those.  What else should I look at?  

Restating the problem:  Win7Pro IE8, where a IE8 page has an email link, when we click the link, an email window launches, but the tab goes blank.  We have to hit the back arrow to get the IE8 page to come back.  When I unticked "enable protected mode" on one of the machines, that fixed it, meaning I can now click an email link and IE8 retains the browser page and opens a new Outlook email in a new email window. The other two machines still have the problem of the tab going blank when the email link is pressed.
0
 
johnb6767Commented:
Are you sure you disabled Protected Mode in the same Zone as the first one?
0
 
rodynetworkAuthor Commented:
Hi johnb6767.  I am in IE8, tools, internet options, security, untick "enable protected mode".  Is there another place to do this?  I am going try something.  Well, I tried logging on as admin and changed the setting and it works when logged on as admin.  But, when I use persons logon which is a standard user, it still does it even thought it is unticked.  So, while logged on to her logon, I tried Start, IE8, run as admin and it worked, but if I run IE8 from her logon by just clicking it (not as admin), the problem persists.  
0
 
johnb6767Commented:
You can enable Protected Mode for EACH zone, which is what I was looking for clarification on....

See this process, to see if you can see the specific Permissions failures.....

Process Monitor
http://www.microsoft.com/technet/sysinternals/utilities/processmonitor.mspx

Save this to the root of C as an Admin, and login the problem user. Do a RunAs with your Admin Credentials to launch it, and then set the the filter at the top to Include "Result" is "Access Denied" then "Include", and then try and recreate the errors by launching the app. Then go look at the logging, and it will tell you where the permissions are restrictive. Once you open those up, keep retrying until you get the desired results....

Keep track of your changes, as they can be scripted to deploy to the other systems......

0
 
johnb6767Commented:

And I would clikc the Request Attention link at the top to request this thread to be reopened, if the problem still exists....

0
 
rodynetworkAuthor Commented:
Ok, have a question. Installed Process Monitor. Have the Filter window up and have "Result" "is" but the next area only has "success" or Unknown" as choices.  I don't see a "Access Denied". So, I have Result is Unknown Include.  What am I missing?
0
 
rodynetworkAuthor Commented:
I don't know. The only two options for "Result" "is" in the filter window are Unknown and Success.  WHen I have Success on it logs so much stuff I can hardly scroll down fast enough to keep up. When I run the filter as Unknown, nothing shows up.
0
 
johnb6767Commented:
After you select "Result" in the first column, then the next one is "include", and the third one you type in "Access Denied".

0
 
rodynetworkAuthor Commented:
Ok. Did that.  I think I'll start a related question.  Can you follow me there?  I don't know how to interpret the logs
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 8
  • 5
  • 5
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now