• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 294
  • Last Modified:

Office Word / Excel 2007 will not open a file if double-clicked

When trying to open Word/Excel files, we get the below message on a client PC:

Windows cannot find 'FilePath\FileName', Make sure you typed the name correctly, and then try again.

Open in new window


I discovered the option within Excel to "ignore other applications that use DDE" and confirmed this fix does NOT work.

According to my understanding, when double-clicking a file, it should send a DDE request to the program which will then open the file.  I'm fairly convinced the error lies in this function, HOWEVER, I have discovered the following:

When I log on, I don't have the same problem
When the program is already running, the file will open

I don't know, but would imagine DDE-related things were not profile-specific, so I'm inclined to say that the above evidence means the problem is not related to those settings, especially because it seems DDE-related settings are stored in HKEY_CLASSES_ROOT.

One other thing I noticed was that Office updates were deployed to the affected client machine on the same day of the occurence, but the user complained the problem was happening before this, just got worse today (at first she couldn't open files which were attachments; today it became any files opened from the shell.

I've tried re-associate the file extension with the program: no effect.  I'm planning to repair Office and/or reinstall, but given that the problem is not present for other logins, I don't hold out much hope.  Also the problem is occuring in a remote office, so copying the files will take all of tonight.  If I can't find out any further clues, I will probably try recreating the profile, but it's a drastic action I'd like to avoid and there's no actual gaurantee this will resolve the problem.

Really, it seems to me there is something DDE-specific which related to your profile, but I haven't a clue what it could be.  Poking around in the registry, I haven't been able to chance upon anything promising.  If anyone has any ideas it would be very much apreciated.  I've also searched the Microsoft Knowledge base, without turning up anything useful.
0
NeoI5theOne
Asked:
NeoI5theOne
  • 2
  • 2
1 Solution
 
cantorisCommented:
Log in as the affected user.  Open regedit and go to :

HKCU/Software/Classes

Are there subkeys in there (ie rather than just under HKLM)  for Office filetypes such as  .doc, .docx, .xls, .xlsx  etc?  If so, why not try exporting those keys (as a backup), deleting them and logging off and back on.  You don't sound like someone who needs to be warned about playing in the registry :)

If you did find entries there, and deleting them didn't work, log in as a working account and see if it has such keys too - if so, export them and then re-import them into the dodgy profile.
0
 
NeoI5theOneAuthor Commented:
Hi Cantoris, thanks for your suggestion; as it happens I did try to repair Office the week after posting and it fixed the problem, surprisingly.  I'll try your suggestion next time as well (I get the feeling this is going to crop up again from time to time in our wonderful environment).
0
 
NeoI5theOneAuthor Commented:
Tried an alternative which solved the problem, but would like to try the suggested fix the next time the problem happens.
0
 
cantorisCommented:
Thanks for giving me points anyway  :)
Good luck next time.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now