ACCPAC pro 7.3 temp data error

I have a win7 x64 PC that I just install AccPac Pro 7.3 that runs from a network share.  It worked on the old Win7 x64 machine.  When I open the program and logon I get the error........

The temporary data directory is not accessible.
(C:Users\John~1.maa\AppData\Local\Temp\)
The system data directory will be used for temporary files.
(x:\PRO73\)

When you click OK the program opens up and all is well.  Sage Accpac said this is a problem with AccPac 7.3 because of a dot in the path for the  temp files, but there isn't and solutions on there web site anymore.  

Anyone remember this and how to fix it?  
mleidichAsked:
Who is Participating?
 
Bill BachPresidentCommented:
Exactly.  Also, we are assuming that TEMP is the variable they are using.  Some apps use TMP instead, so you could try setting both of them.
0
 
Bill BachPresidentCommented:
After you log in, your temp folder changes to your personal temp folder, which includes the dot. In the batch file used to start ACCPAC, issue a SET TEMP=folder call to point your temp table to a directory off of the root folder. Note that you will need to create the folder AND give your domain accout full rights to that folder.
0
 
mleidichAuthor Commented:
This wasn't a problem until I replaced the PC.  I do not seem to have this problem anywhere else.  
It is also started by running "sbtw.exe -t".  There isn't a bat file.  What would the -t switch mean?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
mleidichAuthor Commented:
Anyone have an idea?   It has been days.
0
 
Bill BachPresidentCommented:
I was hoping that someone else would know. You may just have to change your startup icon to point ti a batch file that issues the SET TEMP statement, then changes to the right folder (the start in folder), and then runs your command line (sbtw.exe).
0
 
mleidichAuthor Commented:
Can you give an idea what the bat file would look like.
0
 
jsrebnikCommented:
The -t suppresses the Foxpro license display.

It seems that your batch file or cmd file might just be two lines:

SET TEMP = C:\MYTEMP
sbtw.exe -t
0
 
mleidichAuthor Commented:
I will try this and let you know
0
 
mleidichAuthor Commented:
This will take a few days to get back to, but will let you know if that worked.
0
 
mleidichAuthor Commented:
It works now.  Creating a bat file to set temp files didn't work.

What worked was going into the regedit and changing any temp or tmp to point to c:\temp and c:\tmp.

You both gave me the idea and that worked.
0
 
jsrebnikCommented:
Great!  Please mark my post as helpful.  I'm relatively new as an Expert and could use the points.
0
 
balance776Commented:
This can also be easily solved by changing the environment variables for TEMP and TMP to something that does NOT contain a period in the path, like C:\Temp for example.

this is a simpler fix then going into the registry to make that variable change.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.