?
Solved

Jquery / Javascript

Posted on 2011-09-16
6
Medium Priority
?
458 Views
Last Modified: 2012-06-21
jquery.autocomplete.js jquery-latest.js

The issue is: We have been using classic asp page that have AutoComplete Jquery. It is working fine. However, when we add Jquery-latest.js, the function from AutoComplete Jquery is failed.
Somehow, it looks like they have conflict. I don't ask you to read 10,000 lines of codes.
But in this case, what I can do?
0
Comment
Question by:Webboy2008
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 18

Expert Comment

by:nap0leon
ID: 36551422
Without seeing it in action, my first guess would be to reverse the order that the JS are loaded and give it a whirl.
0
 
LVL 82

Expert Comment

by:leakim971
ID: 36551439
>when we add Jquery-latest.js

look like you add a new jquery lib, use only one jquery lib
0
 
LVL 82

Accepted Solution

by:
hielo earned 2000 total points
ID: 36551464
Other than troubleshooting the plugin, you can:
Option 1: See if there is an updated version of the autocomplete that works with the latest jquery
Option 2: (assuming option 1 did not resolve your problem), go to the jquery site and download older copies of the core library but working backwards until you find one that is compatible with your version of the plugin. So if 1.6.2 is not compatible try 1.6.1. IF that if not compatible try 1.6, etc, until you find the latest version that is compatible with what you have.

On another note, if you post a link to your page, perhaps someone here will be able to solve the problem.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:Webboy2008
ID: 36551486
leakim971: How to do that?
I am not jquery programmer
0
 
LVL 82

Expert Comment

by:hielo
ID: 36551693
The other day I debugged the "latest" of jquery for someone  (at the time 1.6.2) .  
http://www.experts-exchange.com/Programming/Languages/Scripting/JavaScript/Q_27288439.html

You can get a copy of it at:
http://filedb.experts-exchange.com/incoming/2011/09_w37/495810/jquery-1.6.2.js

see if that helps.
0
 
LVL 82

Expert Comment

by:leakim971
ID: 36551719
<script language="javascript" type="text/javascript" src="Jquery-latest.js"></script>
<script language="javascript" type="text/javascript" src="jquery.autocomplete.js"></script>
<script language="javascript" type="text/javascript">
 your javascript code here
</script>
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Styling your websites can become very complex. Here I'll show how SASS can help you better organize, maintain and reuse your CSS code.
Building a website can seem like a daunting task to the uninitiated but it really only requires knowledge of two basic languages: HTML and CSS.
In this tutorial viewers will learn how add a scalable full-width header using CSS3. Create a new HTML document with an internal stylesheet. Set a tiled background.:  Create a new div and name it Header. Position it with position:absolute at the top…
In this tutorial viewers will learn how to embed custom externally-hosted Google Fonts using the Google Font API in CSS Go to the Google Fonts website at google.com/fonts: Browse or search based on font properties or name to find a suitable font for…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question