?
Solved

Iphone user cannot connect to Exchange 2003 Server

Posted on 2011-09-16
11
Medium Priority
?
430 Views
Last Modified: 2012-08-13

Hello Everyone,

I have a user who just recently requested to have their iphone be setup on our exchange server. ( We are running exchange 2003 Sp2) For some reason I can not get their iphone to connect to our exchange server.  I go through all the steps and the veryifying is a success, but when I try to check for mail I get the following message:  "Cannot get Mail  The connection to the server failed"  We have about 20-25 users who have Iphones on our exchange server and NEVER had a problem.  I thought it might be the iphone, so I tried it on two different iphones and an itouch and still it does not work.  I checked the activesync settings on the exchange server and everything is set correctly.  I can log into the user's OWA outside the network with no problem.  I checked all their AD settings against a user who does not have a problem.  I checked the event logs, but I can't find anything related to the active sync.    The other thing you should know I just moved all our mailboxes over to a new exchange 2003 server, but I did not think this would be the problem because all my other iphone users are not having any issues.  Please help!!

Thanks,

Bill
0
Comment
Question by:bjennings
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 5

Expert Comment

by:ErikCamacho
ID: 36551935
I often have to shutdown the iPhone multiple times to get it to work. Also make sure that accoutn does not get locked out.
0
 

Author Comment

by:bjennings
ID: 36552669
I have tried that....I was able to add an exisitng user to the iphone to make sure there wa no problem with the phone.  This user is not having any issue with their account and are able to log into OWA.

Thanks,

Bill
0
 

Accepted Solution

by:
Kevin Kilgore earned 1500 total points
ID: 36552782
Try this:

Go into Active Directory, find that user's account and look at the properties.  Find the "Security" Tab (if you don't see it, click "View" on the Active Directory Menu and then select "Advanced Features".  You should then see the Security tab for that user's properties....once in Security, click the Advanced button and Remove the check mark by the "Inherit from Parent" or whatever it says there and then set the account back up on the phone and try then...
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:bjennings
ID: 36560311
Hello Rauscholeman....After I uncheck the "inherit from Parent" I get a message to Copy the permissions entries or to remove the permission entries........Should I be removing the permission entries?

Thanks,

Bill
0
 

Expert Comment

by:Kevin Kilgore
ID: 36560323
Yes, try removing them and see if that works...if it does not, set it back to the way you had it where the check mark is in the box and permissions are inherited...don't want to mess anything up if this solution doesn't work.  It has worked for my company in the past when we did this....
0
 

Author Comment

by:bjennings
ID: 36562783
I tried it and it did not work....This is really strange because I can add the account to the iphone without any issues.  I don't even think it is hitting the exchange server.....I have a policy to require a password and I am not getting prompted.
0
 

Expert Comment

by:Kevin Kilgore
ID: 36562803
You might try making a backup of the iphone in itunes and wiping the entire phone and see if it will setup from a clean installation.  If not, you can always restore it back...
0
 

Author Comment

by:bjennings
ID: 36562869
I could try that, but I am able to add other accounts to the same phone without any issues.
0
 
LVL 5

Expert Comment

by:ErikCamacho
ID: 36562971
Have you checked your event log on your front end server?
0
 

Author Closing Comment

by:bjennings
ID: 36580610
Hello Rauschcoleman.....What fix this issue is that I had to move the mailbox back to the old server first then do the active sync. I did not think I had to do this because the user I tried this but she could not connect so I thought it was because we had changed servers

 I am going to give you credit because I did follow your suggestion and reset this persons security permissions so that might have also helped!

Thanks again!!!
0
 

Expert Comment

by:FatalException_FL
ID: 37808369
I joined this experts exchange to find the solution to this issue. Unfortunately none of the above resolved my issue of new users not being able to connect to activesync, whereas users already set up worked fine on any device. I also was getting the 3005 409 errors and everything I tried did not work. This is going on 10 months of frustration.

Finally I decided to try the old adage of 'Microsoft setting changes may not apply correctly' and I was leaning towards an issue with the authentication - so I did the following:

1. In System Manager, open Administrative Groups - Your Organization Name -Your ActiveSync Server -Protocols -HTTP
2. Right-click Exchange Virtual Server and click Properties
3. Click the Settings tab.
4. Put a check in the box next to "Enable Forms Based Authentication".
5. Click Apply or OK.
6. Open Computer Management - Services -
7. Find the IIS Admin Service - click on it click restart service. This will restart several dependant services (which is the key here - resetting microsoft registry keys thru this process)
8. Repeat the steps 1-7 listed above, except in step 4 you want to disable the forms based authentication.

And Boom! all of my accounts having this issue suddenly would receive email. While I still get activesync errors 3005 and 409 - the accounts now work. Since everything seems to be working at this time, I'm just gonna leave well enough alone.

I previously had tried the host header and assigned ip 'fixes' as well as the inheritable permissions, and none worked. I also thought maybe it was a certificate issue - which it wasn't. It simply was a case of change a setting - apply - restart - change it back - apply - restart. I assume a Microsoft patch or some other minor config change that occured on the server was the culprit.

This worked for iPhone 4's running 5.1, androids running 2.1, 2.2, and ipad 2 and 3's running version 5+. It really shouldn't matter the device as this was an issue with the exchange server.

Hope this helps someone have a better day.

Derek
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
New style of hardware planning for Microsoft Exchange server.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question