• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 441
  • Last Modified:

RDP resolution not very good in Windows 7----please help

Hello,
Situation:
User connects from home using RDP to his computer at the office, he wants to see tax forms especially all the liens and boxes (user is a CPA)  , office has a windows 2008 server,  user computer in the office is a windows 7 machines.
User computer at home is also a windows 7 machines.

The problem:  the user does not see the lines and boxes in the forms. I have tried to remote  to this user computer at work from different locations but the same problem happens all the time.


The user doesn't have that problem when he uses GOTOMYPC , but he wants to use RDP. I am going crazy with this... anyway...

What I have done:
1) When I start the RDP session (mstsc)  I click in Options, within the tab "Experience" I selected the connection Lan, which allows all the features.    (However, I can't see all the lines and boxes that I see when I access through KVNC)
2) I have tested using a high speed connection -problem the same
3) I was thinking to upgrade the mstsc.exe  to 7.0 as I found in this article:
http://blogs.msdn.com/b/rds/archive/2009/08/21/remote-desktop-connection-7-for-windows-7-windows-xp-windows-vista.aspx
But it says that it already comes installed in Win 7

4) I have tested form different remote locations and the problem is the same.


 I appreciate that you read until this point, I have told the user that he should use an alternative solution *gotomypc* that works, but he again wants to use RDP.

Somebody that can help?
0
anbant
Asked:
anbant
  • 7
  • 7
  • 3
2 Solutions
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Hi, just a small question: did you check the Display tab in the RDP connection settings? Set it to true color or higher. Can you test this?
0
 
anbantAuthor Commented:
Yep I forgot to say that , it is set to Highest Quality (32bit) since the beginning, still the same issue.
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
This is strange, display settings set to 'full screen'?
0
WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

 
johnb6767Commented:
Might have missed this, but how does rdp behave in the LAN?
0
 
anbantAuthor Commented:
Yes , Display settings are in Full screen (max screen)  and  within the LAN I have the same behavior, I cannot see those lines in one column they appear but are discontinuous.
I have selected all the features within the RDP options.
0
 
johnb6767Commented:
If it doesnt work on the LAN, at least you know it is NOT a bandwidth issue.....

What about with something like VNC/LogMeIn?
0
 
anbantAuthor Commented:
Yes , as I mentioned earlier it works fine with GOTOMYPC, BUT the user wants to find out why is not working on RDP.  So that's why I posting my question here because I have tried eveything I could think off and cannot find an explanation.

I even called the vendor for the TAX program and of course they told me that they job ends if the application is up and running locally. I checked the forums of that TAX program but I couldn't find anything.
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Hi anbant, is it possible that you post 2 screenshots?

1 of a local screen and the other of a RDP screen showing the issue?

Thanks.
0
 
anbantAuthor Commented:
Hi  gerwinjansen,
I can't because they are tax forms but I can explain it to you... the tax forms have different lines  (horizontal lines)  that say iten 1 , item 2 , item 3 and so forth along the items there sould be lines where you put the amount ....  

ok in RDP those lines appear in some items and dissapear in others.
in VNC , everything looks perfect.

Thanks,
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Ok, no problem. I just thought I'd ask to make things 'clear'. I'm thinking this maybe a scaling issue because you see some lines and some not. It is possible to set scaling options by modifying the .rdp settings file once you've created one. Setup your RDP connection and make sure that on the tab “Local Resources, “Apply Windows key combinations” is set to “On the remote computer”. Save the connections settings to an rdp file. Open that .rdp file with a text editor and add this line:

smart sizing:i:1

Then look for: desktopwidth and desktopheight and change to a resolution that matches the local screen. Save the .rdp file when you're done. Try some different resolutions and let me know if there's any change.
0
 
anbantAuthor Commented:
Hi gerwinjansen,
I justr tried your solution, which by the way make a lot of sense, but still.... some lines did not appear... a pitty I thought that it was going to work....  I tried different resolutions and everythign  but I am still missing some things...
Thanks  a lot anyway....
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
>> some lines did not appear
I'm only thinking of this now: do other applications, for example Windows Explorer show up normal? If not, can you create screenshot of a Windows Explorer? Thanks.
0
 
johnb6767Commented:
I have a very stupid suggestion, because I dont think it will work.... But have to suggest anyway.....

Right click the shortcut you use to launch the app>Properties>Compatibility, and you will see several (5) options for Display Settings. I would try with each of those individually, and perhaps a combo of a few settings.....

0
 
anbantAuthor Commented:
Hi gerwin and john,
he user is a CPA that does taxes pretty much , so he basically needs this program to work, and yes John I dont know if you are talking about the same but I went to Display  , teste everything within display configuration and leave it set at highest quality.

I had to talk to the user and explained to him that I did everything I could, he understood because I already have spent hours with his PC. So he will need to use another program... it bugs me though that even with all your help there is no a solution...
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
>> it bugs me though that even with all your help there is no a solution...
Well, it bugs me as well, I really would have liked to solve this for you as I've never seen the 'feature' you describe in RDP before (I use RDP a lot with all kinds of clients / servers / displays etc). That's why I was asking for a screenshot :)

Just a closing comment from my side, it may well be caused by RDP itself, see this (somewhat outdated) article: http://support.microsoft.com/kb/925876 - it mentions this:

"When Remote Desktop Connection runs on wide displays or when it spans multiple displays, it may report incorrect values for the GetWindowExtEx() function. Therefore, some applications may display distorted graphics. "

This would at least explain for me why other remote apps are working and RDP isn't.
0
 
anbantAuthor Commented:
Although the problem was not solved the recommendations given by gerwin  made a lot of sense, I work with this problems for several days almost weeks. I think that it must be a problem re to this specific computer.
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Thanks :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 7
  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now