Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

SQL Error

Posted on 2011-09-16
10
Medium Priority
?
753 Views
Last Modified: 2012-05-12
We are trying to change the Reporting server settings so that it no longer use's our exchange relay list / Server.  Just use google SMTP and have it hit a gmail account.

Here is the error I am getting:

Failure sending mail: The server rejected the sender address. The server response was: 530 5.7.0 Must issue a STARTTLS command first. 11sm2223890ybl.27


Here is our config File for the Site we are working at.... advice would be greatly appreciated.

<Configuration>
	<RSEmailDPConfiguration>
	    <SMTPServer>smtp.gmail.com</SMTPServer>
	    <SMTPServerPort>587</SMTPServerPort>
	    <SMTPAccountName>suttonentertainment.inc@gmail.com</SMTPAccountName>
	    <SMTPConnectionTimeout></SMTPConnectionTimeout>
	    <SMTPServerPickupDirectory></SMTPServerPickupDirectory>
	    <SMTPUseSSL>2</SMTPUseSSL>
	    <SendUsing>2</SendUsing>
	    <SMTPAuthenticate>2</SMTPAuthenticate>
	    <From>emailaddress1@gmail.com</From>
	    <EmbeddedRenderFormats>
		  <RenderingExtension>MHTML</RenderingExtension>
	    </EmbeddedRenderFormats>
	    <PrivilegedUserRenderFormats></PrivilegedUserRenderFormats>
	    <ExcludedRenderFormats>
		  <RenderingExtension>HTMLOWC</RenderingExtension>
		  <RenderingExtension>NULL</RenderingExtension>
		  <RenderingExtension>RGDI</RenderingExtension>
	    </ExcludedRenderFormats>
	    <SendEmailToUserAlias>True</SendEmailToUserAlias>
	    <DefaultHostName></DefaultHostName>
	    <PermittedHosts></PermittedHosts>
	</RSEmailDPConfiguration>
</Configuration>

Open in new window

0
Comment
Question by:DG_Dan
7 Comments
 
LVL 61

Expert Comment

by:Kevin Cross
ID: 36553032
Have you tried this with port 465, i.e., SSL versus TLS:
https://mail.google.com/support/bin/answer.py?answer=13287
0
 
LVL 61

Accepted Solution

by:
Kevin Cross earned 2000 total points
ID: 36553045
Additionally, <SMTPuseSSL /> is a boolean setting; therefore: 0 = false, 1 = true. I do not believe 2 is a valid value, but might work as true since it is not 0; however, to be safe, I would change that. Here is confirmation on what the other values mean: http://msdn.microsoft.com/en-us/library/ms157273.aspx

I have not tried to do this myself, so I can't confirm that it is possible; therefore, I checked and found at least this post http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/49fd92b9-810d-4a2c-af18-a63fbf6e1a46/ that suggests you may have to setup smart host (local SMTP server) and have it relay to the gmail server. The referenced other thread shows a configuration with TLS port as you were trying and confirms my point on SMTPuseSSL as it shows with a value of TRUE and not 2.
0
 
LVL 21

Expert Comment

by:Alpesh Patel
ID: 36553060
You are trying to send mail from non secure port. and gmail only working with secure port. so please update port appropriate.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 61

Expert Comment

by:Kevin Cross
ID: 36553084
@PatelAlpesh, thanks for repeating my suggestion. It is always good to get a second opinion. Do you see any other changes that are needed that might help the Asker?
0
 

Author Comment

by:DG_Dan
ID: 36555227
Guys,  I am going to test and try it out Monday Morning, I will keep you all posted with results / recourse.  Thank you for the Suggestions.
0
 
LVL 61

Expert Comment

by:Kevin Cross
ID: 36944774
The issue is probably resolved in the correction of settings or use of smart host - i.e., accept http:#36553045 - but it would be nice to get confirmation from Asker. So may be worth accepting for future readers to know what to try; however, a delete is fine by me also.
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 36998444
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Written by Valentino Vranken. Introduction: The first step of creating a SQL Server Reporting Services (SSRS) report involves setting up a connection to the data source and programming a dataset to retrieve data from that data source.  The data‚Ķ
In this article I will describe the Backup & Restore method as one possible migration process and I will add the extra tasks needed for an upgrade when and where is applied so it will cover all.
Integration Management Part 2
Screencast - Getting to Know the Pipeline

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question