Solved

change fastcgi settings

Posted on 2011-09-17
8
374 Views
Last Modified: 2012-05-12
windows server standard without hyper v  service pack 2  copywright 2007

how to change fastcgi settings

i do not see fastcgi icon on iis manager

is fastcgi properly installed

0
Comment
Question by:rgb192
  • 4
  • 3
8 Comments
 
LVL 9

Expert Comment

by:Lester_Clayton
ID: 36554057
To enable FastCGI do the following:

Add the CGI Role Service to IIS.

 CGI Role
Once you've added CGI, you can go into IIS manager and create Handler Mappings.  If you need FastCGI for PHP, it will create the handler mapping for you.

 Handler Mapping
You should be aware however that some things like PHP which rely on fastcgi will not work if PHP is 32 bit (which it is on Windows), and the server is 64 bit.  PHP will only work with fastcgi if the server, and consequently, IIS, is 32 bit.  
0
 

Author Comment

by:rgb192
ID: 36554125
yes, I did that.

but I still dont see the fastcgi icon in iis 7 manager

and I can only edit 'edit module mapping'  which has four options.
0
 
LVL 9

Expert Comment

by:Lester_Clayton
ID: 36554162
You won't see anything that says Fastcgi except in the module mapping.  When you click "Add Module Mapping" you should see the module "FastCgiModule" in the drop down list for Module, as per my second screenshot.
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 

Author Comment

by:rgb192
ID: 36554302
yes
but I can not edit fast cgi settings in iis7 manager because only the cgi icon is there

0
 
LVL 9

Assisted Solution

by:Lester_Clayton
Lester_Clayton earned 150 total points
ID: 36554310
Ignore the CGI icon.  Go into Handler Mapping and edit or add a new Handler Mapping which will use FastCGI.

 Handler Mapping
0
 

Author Comment

by:rgb192
ID: 36554359
you do not have a fastcgi icon either


on my old windows server 2008, I could click on fastcgi icon and select what error page is shown for a 500error

how do I do this
0
 
LVL 4

Accepted Solution

by:
vaibhavjaiman earned 350 total points
ID: 36555669
you need to install the administration pack for the same

http://www.iis.net/download/AdministrationPack

Also check out the below URL for the PHP fast-cgi setup
http://learn.iis.net/page.aspx/246/using-fastcgi-to-host-php-applications-on-iis-7/
0
 

Author Closing Comment

by:rgb192
ID: 36564662
best answer was installing the admin pack
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OfficeMate Freezes on login or does not load after login credentials are input.
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question