Cannot get my displays to automatically shut down

Running Wn 7 64 bit OS with three monitors and ATI Radeon video adapter.
I have power settings set for dispalys to turn off at 20 minutes. THis initially worked, but now they never turn off.

What else can I check?
M_EpsteinAsked:
Who is Participating?
 
Mohammed RahmanConnect With a Mentor Commented:
Once I had a bad mouse and it use to move the cursor by itself (may be by 1milli meter or less). When that happens the computer will never go to idle in 20 minutes and that will never turn OFF the screen. Try disconnect mouse/keyboard and check if the monitor enters sleep mode.

Also make sure that turn off display is not set to never or any value too high in the advance power options as below.
control panel-power options-choose when to turn off the display-change advanced power options-scroll down to "turn off display after"
 power options
0
 
M_EpsteinAuthor Commented:
For some reason problem resolve on it's own
Not sure why
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.