Preventing Users from Changing System Time using GPO

I have an office running a Windows Server 2008 x64. In this office all workstations are running Windows 7 Pro x64.

Each user has their own workstation. They run an application that requires the user to be a local admin of the machine.

There is also a Time clock software that runs on each computer that each user uses to clock in and out throughout the day. Poor design of the software has left an opening that the time people clock in or out is based on the WORKSTATION time not the server time.

I have Atomic.exe running across the network to keep accurate times, but 2 employees have figured out how to change the time on their macines to suit there purposes.

I would like to create a GPO to control users from being able to make changes to their system clocks but have been unable to find the right place to lock this down.

Can anyone please point me to the proper directory to set this. I'm sure it is simple, but I am just not finding it.

Thanks!
LuukerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

als315Commented:
If your user is local admin, he always will have enough rights.  I think you should invesigate your application, may be full rights for some folders or registry object will be enough.
0
als315Commented:
This policy is here (Change the system time):
Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cantorisCommented:
Use Process Monitor to find out what is wrong with your application - it may just be a simple case of altering permissions on a folder or a registry key.  You really need to ditch your user's admin rights!
0
LuukerAuthor Commented:
Thank you for your input. I will check tomorrow when I get in the office.

I agree I would love to ditch the local admin rights, but the EMR software runs SQL express plus a few other things that absolutely has to have admin rights to run. Usually I am able to simply remove access to things I need to adjust like desktop backgrounds, screen savers, power supply settings, and Proxy information. I set it all using GPO, then remove the menu from the PC so even if they do have rights, the option is gone.

The clock is a bit different though. I want it to stay there, but them just not be able to change it. I will set the GPO in the morning and see what happens.

Thanks for the info!  You guys rock!
0
LeeTutorretiredCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.